Jump to content
Corsair Community

TX750 not enough power for 4890?


Recommended Posts



So i'm having an issue booting up my system. Anyways, it's really weird because the comp was working last night but doesn't work today. I have reseated the things a few times, unplugged replugged tried different PCI-E connectors. I got it to load a total of two times, other times i get 3 flashing red LEDs my motherboard doesn't beep or anything could it possibly be an issue here?


The thing is I don't understand what the issue is, the two times i got it to load i sorta surfed the net for a few mins planning to restart to make sure it works. (I've tried this whole process like 50 times) and upon restart (I don't change any wiring don't mess with anything) it doesn't load again.


I've reset the Bios many times, i'm just plainly out of ideas as to what the problem could be. Help?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...