Jump to content
Corsair Community

HX620W fan spinning slow, computer not posting...


w00derson

Recommended Posts

I have a year and a half old HX-620 and have been having problems with blue screens of death off and on for a while. I have replaced every component besides the PSU. I recently put in a new mobo, cpu and hard drive. It booted up fine and i loaded windows 7. After windows 7 was loaded, it restarted, but would not POST. Occasionally the computer comes on but the monitor stays in "stanbdy". I noticed that the fan on the PSU is spinning pretty slow and not sending any feel-able air out of the back of it. Is this because the computer is not posting, so its in a low power state, or something? The computer turns on and all the fans spin, but it hangs at the opening screen that comes before POST screen. I did the test where you unplug everything but a fan and jump out the black and green wires on the big plug. The connected fan came on, so I guess I passed that. Is there anything else I can test?
Link to comment
Share on other sites

  • Corsair Employees
620watt is sufficient for your system. The fan is designed to vary the RPM in response to temperature. If the system is not posting, then it isn't putting much load on the PSU result in fan spinning at slow speed. you might want to clear CCMOS first and try if you can boot into BIOS with barebone setup.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...