Jump to content
Corsair Community

TX750W and Gigabyte GA-EP43-UD3L mobo -- died and won't start


ean5533

Recommended Posts

Ok, I think I'm losing my mind trying to troubleshoot this problem. I need a sanity check.

 

I got a new power supply (Corsair 750tx) and mobo (GIGABYTE GA-EP43-UD3L) a couple weeks ago. Used the same CPU, just moved it to the new mobo. Everything was working great for those two weeks until the computer just randomly shut off a couple hours ago (instantaneous shut off). A few seconds after I realized what happened, I pressed the power button -- the LEDs in my case flicked on and fans started spinning just for a split second and then died again. Pressing power button again produces same effect.

 

So it seems like the PSU is detecting a short and kills itself, right? Problem must either be the mobo (there actually is a short) or the PSU (falsely detecting a short that isn't there).

 

So I tried the paperclip test with nothing plugged into the PSU except my case's LED lights. Fan started spinning on the PSU, and the lights lit up. Ok, so it must be the mother board.

 

Swapped back to my old mobo, put my CPU back into it. Plugged in just the ATX cable and case LED power, hit the button, and... nothing. PSU was plugged in and turned on, power connectors were all there, power switch was plugged into the motherboard, and zero response. (Not even a quick flicker of power like I was seeing with my new mobo).

 

So I re-did the paperclip test with nothing plugged into the PSU at all. Still worked. So maybe the paperclip test is lying to me? I went and got my old PSU back and paperclipped it; worked fine of course. Plugged the old PSU into the old motherboard, got everything back to exactly how I had it two weeks ago, hit the power, and everything turned on.

 

Just to reconfirm that I hadn't screwed up my tests, I paperclipped the new PSU again and it worked, but when I plugged the new PSU into the old mobo, no power at all.

 

When plugging old PSU into new mobo, things work.

 

So now we know that :

 

  • My old mobo and old PSU work when plugged together
  • My old mobo and new PSU do not work when plugged together
  • My new mobo works with my old PSU
  • My new mobo turns on just for a split second with my new PSU
  • In spite of the obvious conclusion that the new PSU is bad, the new PSU still passes the paperclip test.

 

Am I missing something obvious here? Is there any way the PSU could still fail even though it passes the paperclip test? Is the paperclip test not the holy grail that I thought it was?

 

Sorry for the exceptionally long post, but I felt like I was going insane trying to troubleshoot this.

Link to comment
Share on other sites

I would suggest you to pull out the motherboard and place it on a non-conductive surface, then connect the PSU and a fan to the bare motherboard and see if you can power up the fan.

 

Unfortunately, I've already got the PSU packed up and ready to ship out for RMA, so I won't be able to perform this test.

 

However, if this is the problem, I can't see how it could have suddenly only become a problem 2 weeks into usage (but I'm definitely no expert, so I'll defer to you on that)

Link to comment
Share on other sites

  • 3 weeks later...
Let us know how it works out with the replacement PSU.

 

I received my replacement PSU yesterday and everything seems to be going great. I didn't hear back from Corsair what exactly the problem was with the unit I sent in, and I'm a little curious, but my laziness outweighs my curiosity.

 

I'll follow up if anything goes wrong again. *fingers crossed*

Link to comment
Share on other sites

Update:

 

PSU worked fantastically on Wednesday, Thursday (yesterday), and this morning. Today when I turned on the computer I went into the BIOS to set the DVD drive to load before the HDD, and the computer instantly shut off after I saved my BIOS changes.

 

I turned the computer off and re-entered the BIOS -- settings had saved. I reverted them back to what they used to be, figuring that had somehow caused the problem. Saved and exited, got about half way through loading my OS, then the computer instantly shut off again. Restarted one more time just for kicks, instantly shut off before it even finished the normal startup mem test.

 

After taking my anger out on several puppies and a small child, I waited ten minutes, opened the computer case, and started the computer. Everything loaded fine and It has been working since then. My computer case is now sitting open and I'm afraid to close it.

 

I have a few theories (ordered by how probable they seem to me):

 

  1. A wire is touching the motherboard and causing an issue, but with the case open the wire doesn't touch the board anymore (is this possible? We're getting outside my area of computer knowledge)
  2. Memory is bad (I ran a manual memtest and it passed ok)
  3. I am cursed
  4. Corsair has an on/off remote control and they're playing with it and laughing at me

 

Any other ideas?

 

P.S. No puppies or children were actually harmed. You can call the FBI back and let'em know situation has been cleared.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...