Jump to content
Corsair Community

TX750 better than HX850 ? Core i7 3.2Ghz problem


bivoy

Recommended Posts

Edit 2014 ....

new link to gallery for adaptor ATX PSU >> HP z400

material needed

ATX extender cable from which you remove 3 wires, which are different on HP vs ATX std.

1-2 Molex to something adaptors, which you use to get proper (HP spec) voltage to those 3 pins

30 minutes of time and some needle to remove pins from headers and put it elsewhere

https://plus.google.com/photos/111388964237560787781/albums/5362166283613539361?authkey=CPmyw--dmNrUbw

Link to comment
Share on other sites

  • Corsair Employees
No it is not that 750HX is better than 850HX. It sounds like your system requires a proprietary PSU, and it may not follow the standard ATX voltage requirement/design. Corsair PSUs are ATX v2.2 standard and backward compatible to ATX v2.01; they are not guaranteed to work with non-ATX systems or old ATX standard systems.
Link to comment
Share on other sites

No it is not that 750HX is better than 850HX. It sounds like your system requires a proprietary PSU, and it may not follow the standard ATX voltage requirement/design. Corsair PSUs are ATX v2.2 standard and backward compatible to ATX v2.01; they are not guaranteed to work with non-ATX systems or old ATX standard systems.

 

I added picture of original HP wiring scheme, see link to pictures gallery, except 3 pins it is the same as ATX 24 pin std.

Corsair whis works fine is older TX, not an HX. Not working is HX series .... May be it is too new spec ....

As long as TX750W is working perfectly I do not care, but I was curious what could be the reason of this problem with HX850W

Link to comment
Share on other sites

Hi, I have an HP Z400 workstation as well, and attempted to upgrade the PSU. I was trying to use the Corsair TX650W, and got the same power supply failure beeps as you did. Thanks for finding out the reason: likely the different 24-pin ATX pinout. Do you have a picture of the adapter you made? I would be interested to try something similar.

 

One suggestion as to your problem, possibly, is that the HP 475W supply actually outputs 5.1V, not 5.0V. If the motherboard actually checks for some min voltage like 5.05V, then I could imagine almost randomly that some PSUs would fail if they are intended to only output 5.0V. Could that be true?

Link to comment
Share on other sites

Hi, I do not think that 5.0 vs 5.1 will be problem, because it is still within ATX specification. I think that HDD molex rails on HX850 are weaker than on TX750, or HX850 is just not single rail PS as specified - that is OK for majority of users, because in normal circumstances you got on HX dedicated wire for everything you need.

Or HX850 got slightly different wiring/spec than TX750 - this one I did not check carefully.

As an alternative to adaptor you can use additional power supply for graphics into 5.25 slot, google + for "booster x3 /x5".

Main reason why I changed HP power to Corsair was power supply fan spinning up in 3D mark 06, slightly, far from maximum .... but audible :laughing:.

For adaptor you will need ATX 24pin extension cable, one or two Molex to P4 (CPU) power adaptors, and some tools to remove Molex pins from connectors without destroying them (you can buy it on internet, or use needles, I used special dentist tools :bigeyes:). Then remove correct pins from extension cable, and plug into those loose holes two yellow and one black cables from Molex/P4 adaptors, metal pins will fit, and then plug ATX 24 pin from Corsair into adaptor + 2x HDD molex plugs.

I will link picture later this week ::pirate::

Link to comment
Share on other sites

  • 2 weeks later...

problem with hx850 solved - it was dead itself. So I returned it to reseller, get money back , bought new HX750 as it was available on stock, and it also works with HP Z400 & cable adaptor, the same way as TX750.

Here are some pictures of self made Z400 power supply cable adaptor to work with Corsair (and other) power supplies ....

...see link in lasy message or search google for HP z400 power supply adaptor

Link to comment
Share on other sites

  • 7 months later...
  • 3 months later...

How did you get an HX750W to fit in the HP z400 case?

 

I have a z400 (refurb) from HP Customer Relations as replacement of an earlier model workstation that died under warranty. I want to put five drives and a hefty video card in it, so I got the HX750W.

 

But it won't fit in the case! Well, it fits, but there aren't appropriate holes that line up to screw it into place.

 

Only two of the four mounting holes in the power supply have matching holes in the case frame, and they're not in the right places for a two-screw mount -- they're both on the same short end of the power supply. It would not be secure at all.

 

What do I do? I'm a novice with serious business to take care of and this is getting costly in terms of time. I went to the store to buy one of these after posts on another forum said to get the Corsair TX750W and I felt the HX was just more sensible. I asked on the forum how I'd know if it will fit and they only spoke about wattage and connectors but never responded about fitting properly in the case. They told me at the store that these things are all "standard" sizes.

 

Any advice, please, would be hugely appreciated!

 

Thanks.

Link to comment
Share on other sites

I solved my issue of physically fitting the HX750W into the z400 case. I just used mounting tape underneath the power supply where it rests on the case (when the case is opened and laying flat). Together with the two screws that do line up with the case, it did superbly well.

 

Now I want to deal with this wiring issue.

 

I've found a few things that indicate that the power supply in the z400 is customized:

 

Check out the first sentence in this z400 data sheet on the HP site.

 

And the middle of the "Innovation..." paragraph on page 1 of this z400 info document.

 

Also, check out the “HP WattSaver” section at the bottom of this page on an HP "UK" site.

 

And you can see the phrase “Power Supply – 475 watt custom power supply - (Wide Ranging Active PFC)” if you search for the word “Custom” on this Russian HP z400 info site.

 

So, my questions, please, are:

 

Is there any chance we're losing something important with this wiring adapter in terms of the "custom" power features of the z400?

 

Or are we pretty sure it will work just the same as the supplied power supply?

 

And if we're sure it will be okay, any chance I can please get more explicit and/or updated explanation of how to make the adapter and what it's doing, so my tech guy can take it from there?

 

Thanks a million!

 

Jay

Link to comment
Share on other sites

Now I want to deal with this wiring issue.
It sounds like your system requires a proprietary PSU, and it may not follow the standard ATX voltage requirement/design.

 

Unless HP can GUARANTEE their PSU meets ATX 2.01+ standards and that their motherboard uses the same standard, it is not recommended to use a PSU that meets ATX 2.01+ specs.

Link to comment
Share on other sites

  • 4 months later...

HI All

Its a year and half and HX750 inside z400 works perfectly. Now I got GTX 580 after Radeon 5870, both run smoothly :)

 

Things to remeber :

- original HP PSU height is bigger than std ATX, so after replacement there will be small space left below new PSU, aprox. 0.5 inch

- you have to drill 1 hole into new PSU to mount it on full 4 screws

- you have to choose new PSU (like corsair hx750) with L shape SATA power connector , in other case you will not close side chassis cover as HDD are facing left side of chassis, and if SATA power connector height is too big ....

- you can create adaptor without soldering , just remove pins from one connector and plug it to another

- adaptor is removable , no changes to power supply (except one hole ;))

 

forgot to mention - HP just released Z400 PSU 600W with 2x6pin ....not good for GTX580, but good for one class lower cards ...

Link to comment
Share on other sites

  • 3 years later...
  • 4 weeks later...

Hey Guys,

thanks to Bivoy for providing and updating the pictures of the adapter.

Does this work with any ATX 2.2 (and upwards) PSU from any manufacturer?

 

/Edit: I want to upgrade the Z400 with a GTX 770 GPU and I'm not sure if the 475w-PSU can handle it, so I'm thinking about upgrading the PSU too.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...