Jump to content
Corsair Community

BSOD Trouble


Recommended Posts

I just DIY a new PC. The mainboard is ASUS M3A78-EM(integrated video card ATI HD 3200);Memory is CM2X2048-6400C5(only one);CPU is AMD 7750 Black Edition. When I powered on the computer and saw the windows xp progress bar, the screen became blue. the blue screen code: PFN_LIST_CORRUPT,STOP 0x0000004E. I search the problem from Microsoft which told me there're several possibilities below:(by the way, I never overclock my cpu or memory)

1. I/0 device conflict or driver conflict.

2. Check whether your ram is damaged.

3. Check whether you have installed some new software.


Therefore, I download the Memtest86_3.5.iso and test this corsair memory several time, but it never found any error or fails. So this test could prove my corsair memroy has no compatibility problem? I should keep my eye on the driver conflict or software conflict?

Can somebody give me some advices ?Thanks a lot.

Link to comment
Share on other sites

Please use http://www.memtest.org Version 2.11 to test the module and just load setup defaults and then disable legacy USB and test the module.


Memtest86 3.5 Release (3/Jan/09)

I used that is the later than what you told me used. I think they are no much difference, do you think so?

I just wanna know the moudule passing all the test could prove there's no compability problem?

Link to comment
Share on other sites

Please use the version I suggested the version you have is known to have issues with these chipsets.



Anyway,if my memory cann't pass memtest86 v2.1 test, I just chang it. But if it can pass the memtest86 v2.1 test, it can prove that memory 's ok and there's no compability issue with it?

Link to comment
Share on other sites

I have no idea about this issue. I tested this memory more than 8 hours by mentest v2.1, and no error was found. I also update the chipset,VGA,audio drivers,but there're still the same BSoD (PFN_LIST_CORRUPT). Some suggested me that I should update XP SP2 to XP SP3. Could it really work? I am going to relpace a new memory to check it. The following are windbg reports:


0: kd> !analyze -v


* *

* Bugcheck Analysis *

* *




Typically caused by drivers passing bad memory descriptor lists (ie: calling

MmUnlockPages twice with the same list, etc). If a kernel debugger is

available get the stack trace.


Arg1: 0000008f, The free or zeroed page listhead is corrupt

Arg2: 0005df3d, new page

Arg3: 000426bd, old page

Arg4: 00000000, 0


Debugging Details:












IRP_ADDRESS: 8a3ed408


LAST_CONTROL_TRANSFER: from 8051d9e2 to 804faf0d



ba4c37f8 8051d9e2 0000004e 0000008f 0005df3d nt!MmDeleteKernelStack+0x15e

ba4c3840 80697b94 8a3ed448 00000000 00000044 nt!IopCompleteRequest+0xde

ba4c3dac 805cfca2 80086000 00000000 00000000 nt!KdpSearchPageHitOffsets+0x994

ba4c3ddc 80546ebe 8069690c 80086000 00000000 nt!`string'+0x2

ba4c3e18 00000000 00000000 00000000 00000000 nt!ExpInsertPoolTracker+0x7b







804faf0d 5d pop ebp




SYMBOL_NAME: nt!MmDeleteKernelStack+15e








IMAGE_NAME: memory_corruption


FAILURE_BUCKET_ID: 0x4E_8f_nt!MmDeleteKernelStack+15e


BUCKET_ID: 0x4E_8f_nt!MmDeleteKernelStack+15e


Followup: MachineOwner




Link to comment
Share on other sites

I finally solved this issue. After replacing another memory, everything is ok. Therefore, my BSOD is caused by that memory. It's weired. Though it past memtest86+ test, and no error found, it could not prove your memory is definitely good. If your memory can not pass the memtest86 test, you should be sure your memory is bad.


Thanks for your help!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...