Jump to content
Corsair Community

Corsair CMPSU-750TX emitting long beep at startup.


Recommended Posts



I purchased a CMPSU-750X on 12/1/2008 from Newegg.com.


The problem:


Ever since I purchased the power supply when I do a cold restart I get this 1 long beep coming from the computer and it will not even get to the start up BIOS or whatever that black screen is called. The only thing I have been able to do to get it to work is if I sit there and hit the reset button about 10+ times . Also just recently it will randomly shut off. The few times that has happened it has been when I was gaming.


Why I think it's the power supply:


Because the power supply was the last part I installed in my computer. Before that it worked fine.


The fact that I can sit there and keep hitting the reset button and after X amount of times it will work gives me the idea that maybe a capacitor is slowly charging over that time and then when it has enough charge it works.


Why else would it just randomly shut off?


What I have and what I can't try:


I have tried a different power outlet. I can't try a different power supply because I do not have one that will support my hardware at the moment.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...