Jump to content
Corsair Community

ASUS Striker II Formula & TWIN2x4096-8500C5 G


Recommended Posts



I recently had to RMA this board and have had a replacement fitted. The RAM is set with the timings 5-5-5-15 2T with the Voltage to 2.1V


Every 2nd boot I get a long continuous beep and it won't POST, but restarting it seems to clear that, and it boots ok. Looking through google, seems I may need to set something up differently for the RAM, so is there anything I am missing ?


This new motherboard seems to have different options in the BIOS, and I cannot see anything for EPP (SLi memory option is disabled for some reason says something about DIMM .2 needed)


Any help is appreciated.

Link to comment
Share on other sites

Yeah I did, thing is, the modules were working perfectly, before the motherboard failed, since the new mother board has been installed, I get the boot problem. It may not be RAM related, but I want to rule that out before I have to send the PC back.


Are the rest of these settings ok too ? :


tRRD 3

tRC 22

tWR 4

tWTR 9

tRER 7.8uS (? not sure if I wrote that down right)

tRD 7

tRFC 51


(These are all on Auto)


The BIOS is the latest, and I have the RAM & CPU unlinked FSB at 1066 and RAM at 1066


Once I get the settings correct again, i'll run memtest fully, although vista memcheck reports no problems (Was a quick solution I ran earlier)


I've just noticed in the BIOS that the timings are set at 5-5-5-15 , but it wont accept 15, and sets it to 18, this is comfirmed in CPU-z


I have a horrible feeling about this... i'll check it again.

Link to comment
Share on other sites

  • Corsair Employees
Try the TRC set to 24 and tRRD at 4 or 5 but Auto should work fine, did you test the modules one at a time to see if you can isolate the problem to one of the modules? And does it have the latest BIOS version installed?
Link to comment
Share on other sites

ok I have found the problem, and I apologise for this. It turns out the PC Company that built the machine when they replaced the motherboard, they also took out the 8500C5 and replaced it with 6400C5, so no wonder I couldnt get it to run at 1066 properly. The timings are supposed to be 5-5-5-18 for this RAM, and voltage is 1.8 which i've set to 1.9 as I remember it was more stable.


Apparantly this motherboard, the Striker II Formula will not work with the 8500C5 , or it will work but is extremely unstable.


Thanks RAM GUY, the system is booting ok now, it was either the incorrect settings causing it (as the system was in overclock mode) or one of the modules wasn't seated properly.


Is the 8500C5 really that unstable on this board ?

Link to comment
Share on other sites

Yeah seems most of the older ASUS boards are rubbish with faster high spec RAM, although it was working fine with the 1066 speeds before the board blew. Turns out the PSU was the reason.


Time to dump it I think and use a better company than ASUS for it all, and go DDR3, i'm sick and tired of hassles with this setup.


Thanks RAM GUY , as always you are a big help :)

Link to comment
Share on other sites

Hi again,


The company have sent me replacement RAM, and it's the Dominator RAM




Now I have installed the two units, set the timings to 5-5-5-15 and voltage to 2.1


System boots no problems, but in CPU-z the timings are showing up as 5-5-5-18 and the DRAM Frequency is 400


I've set the BIOS to UNLINKED and timings for FSB and RAM are both 1066


It is the latest BIOS for the motherboard. Any ideas why this RAM seems to be running slowly ?


btw , I ran memtest for 4 passes, not one error, and like I said, BIOS revision is the latest from ASUS


Here are two screenshots showing what I am seeing in CPU-Z they contradict each other




But then there is this




The EPP is showing the correct timings and frequency, yet the other tab shows it's running at 800mhz. I'm confused, any other way of checking which is right ? Do I need to enable SLI memory in the BIOS ?

Link to comment
Share on other sites

Right forget technology, forget anything complicated, this all comes down to colour lol


I took the RAM out of the white slots on the board, put them in the blue, and they are bang on 1066 now working with the correct timings. This was the same with the Standard C5 so must be something motherboard related, although I don't know what.


Thats a fix for the Striker II Formula and 8500 (1066Mhz) RAM, strange but true.


have a nice day :D

Link to comment
Share on other sites

  • Corsair Employees
If just changing the DIMM slots fixed the problem you may want to contact Asus and make them aware of your results. If sounds like the issue could either be with the memory controller on the board or possibly a DIMM slot.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...