Jump to content
Corsair Community

New TX750W - Doesn't power on when connected to mobo


Recommended Posts

Hi All -


I recently (yesterday) received a Corsair 750W power supply to replace an old 450W unit.


I installed everything and powered up the system. Everything worked fine. I used the system many times that day including copying files, music, playing games, some software work in Visual Studio. Everything worked well and the system was more stable than it had been.


I went to bed and woke up 8 hours later to find the system off. I attempted to turn everything back on but the fans (power supply and CPU fan) would only spin for a half second or so and then stop. The mobo light indicated power.


I checked all connections to make sure everything was well connected and tried again. No go.


I removed all but the basic components and tried again. This failed as well.


At this point, I hooked my old power supply up and uninstalled the corsair. The system started up just fine.


I jumpered the corsair PSU to see if it would turn on. It turned on fine and would power a couple of old cdrom drives that I had lying around.


Anyway, here's the recap/TLDR version:


New System (build 1/5/09) doesn't work with New TX750W (though, it did for the first 12 hours)

New System (build 1/5/09) DOES work with old 450W PSU.

TX750W powers on via jumper, but not when connected to mobo via 24pin connector (also tried as 20-pin.)


Any help would be very much appreciated.




Fixed some typos. I said does not when I meant to say DOES.


Also, I hooked the TX750 up to a mobo, ram, video card, and 2.4ghz P4. It spins the fans constantly (i.e. doesnt turn off) but the system never posts/boots.


I received the same results when testing the PSU on a 3rd system. Fans spin, no boot. However, on my main system the fans won't even continue spinning.


Bad PSU?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...