Jump to content
Corsair Community

Need Help troubleshooting TX750W


Recommended Posts

When i try to switch on my system, processor and SMPS fans run for hardly couple of seconds and then system shuts down. In the mean time no display is shown.


I tried changing processor to E8600 and system starts fine. So I am not understanding what can be reason for smps not working with my config.


BTW I have confirmed other components working individually on another system.


I have deposited SMPS to local service center few hrs ago. But if i find a solution here in sometime, might consider taking it back rather than waiting for a week to get replacement/ repairs.


Any help in this regard would be appreciated. Thanks in advance.

Link to comment
Share on other sites

Yes i connected both 24pin and 4pin (12V) cables to motherboard.


Following are the combinations i tried for isolating problem but still dont understand the logic behind this wierd bahavior.


E8200 + G31- ES2L + XMS2 2 x 2 GB ram + TX750W = system does not boot


E8600 + G31- ES2L + XMS2 2 x 2 GB ram + TX750W = system does boot


E8200 + G31- ES2L + ******** 2 GB module + 2 Different SMPS = system does boot


E8200 + G31- ES2L + XMS2 2 x 2 GB ram (all possible combinations of these modules) + Different smps = system does boot



When i tried first two cases, I thought problem must be with processor... but eventually got processor back from Intel RMA with NDF (No defect found) as screening result.

Link to comment
Share on other sites

  • Corsair Employees
E8200 and E8600 are based on the architecture and core; logically if one works then the other should as well. If you already have the latest BIOS update, then let's go ahead and try to replace this PSU for you. You can use the On Line RMA Request Form and we will be happy to replace it. Be sure to check the box that says “I've already spoken to Technical Support and/or RAM Guy.”
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...