Jump to content
Corsair Community

How to get an RMA


Recommended Posts

I know I have a bad part. I have TR3X6G2000C7GTF. All three sticks worked correctly when I received them. Running on Classified 759 MB. Used XMP profiles and correct memory timings were set automatically. Was running 2:10 x 200 Bclk with no issues.

 

I leave my computer on most of the time. I came home a couple of days ago and the screen was black on my monitor. I tried rebooting but would never get past the EVGA logo screen. I suspected memory and reset CMOS but still could not get into BIOS. I tried each module one stick at a time at BIOS default settings for i7 920 processor. I set the voltage at 1.65 after the first stick booted and all worked fine. Only one stick would not work. I can't even get any response when using this stick by itself. I'm pretty certain it is dead. I have three sticks of DDR3 1600 from another manufaturer and it still works perfectly in the same system.

 

I sent an RMA request in yesterday and it has been more than 24 hours and I have not received a response.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...