Jump to content
Corsair Community

Memory fan making horrible noise


Recommended Posts

I just bought a Dominator GT TR3X6G2000C8GTF kit w/memory fan about 2 months ago. Now the fan is making this ridiculous high pitched squealing noise whenever i turn it on, do I go through the same RMA process for this? I don't seem to see any options for it.
Link to comment
Share on other sites

I have the same issue. when I first start the computer the fan wails for about a minute and then settles in nice and quite.

At best its annoying and at worst the part fails all together. Will I be without a fan while I RMA this part? I purchase this through the Corsair shop

Link to comment
Share on other sites

Yeah that's the exact same thing mine does, only in the last few days it's gotten worse. Now it either starts back up again after a few minutes, or it just doesn't stop making that whining noise at all. It would be nice to get an answer about this.
Link to comment
Share on other sites

One of the cooling fans in my set is sounding like it's trying to commit suicide. I'd like to know if I could just replace the fan through Corsair, without sending the entire set in. It still runs, but that one fan wobbles and grinds when I start up my computer. After a while, it just wobbles... Worries me. When's it finally going to die?

 

Nothing's busted but the fan. I'd totally buy another fan for it myself, but I like the sticker on the fan and I'm sure I would not be able to get it to look as good.

Link to comment
Share on other sites

  • 2 weeks later...
  • Corsair Employees
That should be fine as long as the part number had the "F" at the end, if not you should call and talk to our customer service to make sure the part number being returned will include the fan.
Link to comment
Share on other sites

  • 3 weeks later...

Ok, after shipping this, it finnaly arrived to corsair and was refused for "damage and/or open package" I wont get into that since it was merely 1 layer of popped box tape.

 

I the package eventually made it back to me, naturally I was out of town for work so it sat.

 

Do I simply reprint the label and reship, or will I need a new RMA?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...