Jump to content
Corsair Community

Thumb drive doesn't assign drive letter after format


kencl

Recommended Posts

Hi Folks,

 

I recently purchased the Flash VoyagerGT 16 Gb. Very nice indeed! I initially formatted it exFAT to support large files. No problem - worked like a charm. Then I wanted to use it on a friends computer, so I came up with the idea of partitioning it into 2 logical drives, 1 small FAT32 partition to contain Microsoft's patch for XP which supports the exFAT file format, and the other partition simply exFAT to continue supporting large files. I used an old version of Acronis's Partition Expert 2003. Well, ever since then my main computer no longer assigns a drive letter to it. The odd thing is that I can plug it into another computer in the house, also WinXP Home, and it assigns it letter E: in Windows Explorer. My main computer, the one which can't see the drive, already has an E: partition, but I did not assign it a drive letter when repartitioning it.

 

I repartitioned it a second time back to a single partition, then reformatted it using Windows Explorer on the other computer back to FAT32. Well, it works fine on that computer, but not my main computer. I can see it in the Device Manager as the "Corsair VoyagerGT USB device", but no drive letter is associated with it. Did I mess up the master boot record or what did I do wrong? More importantly, how do I fix the problem??

 

Here's a little more info on what Device Manager sees:

General Tab: "The device is working fine"

Policies Tab: Both options are grayed out???

Volumes Tab: All entries are just a single dash "-" character

 

Thanks!

Link to comment
Share on other sites

Ok, I tried what you suggested. No luck. I had to install SD Formatter on the other system because it didn't detect the drive on my main system. Why would it be that one computer detects it just fine while another one doesn't?

 

I'm a relatively advanced user, so I have no problem safely editing the registry for example. I'm really stuck here. Thanks for the help.

Link to comment
Share on other sites

  • Corsair Employees

Sounds like you need to reinstall the mass storage drivers on that system.

Go to device manager with the USN drive connected and remove anything listed for the Flash drive then one that is removed remove the drive from the system and remove everything listed in USB Controllers and restart the system. It will reinstall all of the USN controllers.

Link to comment
Share on other sites

Thanks for the help. I've gotten it working again. I didn't have to go so far as to reinstall all the USB Controllers, only the Disk Driver for the thumbdrive itself.

 

So, for anyone else whom this thread hopefully helps, there are 2 things I did which you also could try. Firstly, after recombining the 2 partitions back into 1, I set it as an active partition, and secondly, with the thumb drive plugged in, I went into the Device Manager where, under Disk Drives, I deleted the entry for the Corsair VoyagerGT USB Device, removed the drive and rebooted the system.

 

I'm really happy with this thumbdrive. I'm using it to transfer movies with filesizes as large as 9 Gb PVR'd by my TV tuner card to my wifes system. This is way faster than doing it over the wireless G LAN would be :eek:

 

Keep up the great work Corsair!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...