Jump to content
Corsair Community

HX1000 Does not power up after a few reboots.


toohai

Recommended Posts

Hi,

 

I just got a HX1000w from Singapore during my two week visit there.. when i got back I connected it to my PC to replace my 500w old PSU of some brand which i forgot.

 

It powered up a few times randomly after 3-5 tries each time..after rebooting a few times to remove some extra hdd in the casing to install into my NAS. After a the 2nd or the 3rd it did not on at all.. it just spins the fans and all a little and stops each time i try.

 

And then i have to disconnect power and wait for a while before retrying and it does the same.

 

I tested it with only the mobo connected and it still did not work. I also tried powering it up with a cd rom connected using the pin method with green and black.. the same thing happens.. it just spins the fan and just stop..

 

Also i haven't noticed any sparks, smoke or abnormal smell from the psu.. i looks ok from the looks.

 

Please help... i had to pay a fortune to get this one.

 

Is there anything else i can try to check the PSU is working.

 

Thanks,

Link to comment
Share on other sites

  • Corsair Employees
If its failing the paperclip test then the unit may require replacement. If possible I would test the PSU in a different system just to be certain that the problem follows the PSU. If it looks like a replacement is necessary then please use the On Line RMA Request Form and we will be happy to replace it. Be sure to check the box that says “I've already spoken to Technical Support and/or RAM Guy.”
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...