Jump to content
Corsair Community

Corsair P256 CMFSSD-256GBG2D / Mac OS X / MBP

Recommended Posts

  • Corsair Employees
Thanks for the update, there have been a few people with similar problems, all using the newer Macbooks with the nVidia chipset, although it doesn't seem to be all of them that have the problem. I would keep an eye out for any firmware/OS updates from Apple, as I would suspect an update is the only way that the problem could be resolved.
Link to comment
Share on other sites

  • 2 weeks later...
  • Replies 65
  • Created
  • Last Reply

I hate to say it, but I have the P256 installed in a MacBook Pro 5.1 (Late 2008) and it is running fine. The only difference is I installed a clean version of 10.6.

Maybe there are better drivers in it for the Nvidia chipset?


Maybe it is worth a shot to get a 10.6 image from the net to see if it will work.


I have a MacBook Pro 5.1 with 4Gb of ram (from another vendor though :o:) with the P256 installed.


If you really want to I could do a fresh install of 10.5.x (don't know what version the DVD is) and see if I have the same problems.

Link to comment
Share on other sites

Early 2008 15" MBP / 2.66 C2D / 4GB / NVidia 8600GT


Put the P256 SSD in the chassis in less than 10 minutes. I had previously cloned an image to an external FW800. Cloned it back to the P256 in the machine. BAM! Away she flies!


So much faster now. Benchmarks show it, but real-world computing confirms this is the best upgrade I have ever done in 25 years of personal computing.


Huge directories open in icon view *instantly*, My 40GB Lightroom DB opens **instantly**. MS Word 2008 (SP2) used to open in >3 minutes, now opens in <3 seconds (from uncached fresh boot)! Holy smokes it's fast. Uncached Photoshop CS4 Extended opens in 3 seconds. Illustrator, too. Acrobat 9 launches instantly cached or uncached. It's as fast if not faster than Preview!


All I can report is supreme satisfaction. I don't know why the OP's system was slow. Mine is ridiculously fast .

Link to comment
Share on other sites

quick followup: that was a month ago. My system is even faster now! due to some duplicate/corrupt font problems that I resolved with FontFinagular and reinstalling MS Office.


So 30 days later and faster than when I first switched to the new SSD.



Link to comment
Share on other sites

Curiously, there is alot of talk about cloning in old drive and restoring it back to a freshly formatted SSD on Vista. And on this i have seen people talk about "alignment" problems. I dont know what this means but i am curious if there are such issues with a mac as well? I may have to erase my disk and restore an old cloned image but if this would be detrimental to drive performance on my mac i guess i could do a fresh install and move back everything from the cloned image...
Link to comment
Share on other sites

  • 4 weeks later...

Hi Torsten,



This is a follow-up to Bug ID# 6874221.



Engineering has provided the following feedback regarding this issue:




The Corsair SSD is a SATA Gen2 drive, which means its interface is rated to run at the 3.0Gbs. The MacBook Pro does not support Gen2.



You may want to consult with Corsair as to how you can get the SSd to run at Gen1 (1.5Gbs) speed.



We consider this issue closed. If you have any questions or concern regarding this issue, please update your report directly (http://bugreport.apple.com).



Thank you for taking the time to notify us of this issue.



Best Regards,




Apple Developer Connection

Worldwide Developer Relations







Bug ID #: 6874221

Bug Title: Low Speed on Mac OS X 10.5.6 / Mac Book Pro 5,1 / Corsair CMFSSD-256GBG2D


<GMT11-May-2009 09:52:49GMT>

hi i recently bought the P256 CMFSSD-256GBG2D and the performance on mac os x is really poor. i think it is a driver or controller issue in the late 2008 macbook pro´s. exact model is a macbookpro5,1



example: i tried to install xcode 3.1.2, at the same time i tried to open safari, the complete computer stuck for 30 seconds. it happens everytime if i do 2 things where one thing is a heavy file operation.





my macbook has 4gb ram, the problem only occurs with more than 2 gb ram. if i remove a 2 gb module the ssd runsfine.



in my friends mbp 4,1 with intel sata controller the ssd runs fine also with 4 gb ram.



i hope there will be a fix





Link to comment
Share on other sites

i always had leopard installed. now i installed snow leopard and the issue is still there. and to make things clear, its not a fault of corsair, i just wanted to share the answer apple gave me.


i know it would be stupid to think that corsair releases a firmware which reduces the speed to sata 1 speed.


its just an information for you that you can close this thread.


conclusion is that apple cant deliver notebooks with full sata 2 speed.

Link to comment
Share on other sites



GOTO that link and follow the directions.


I ran into this thread researching Corsair P256 SSD. Trying to decide between it and ********'s. RAM GUY has been a huge help to me in the past, so I thought I would help out here. BTW, Corsair needs a way to update firmware... for me to buy one.


EDIT: But I think you may already be aware of this... So the MBP with Firmware 1.7 is not really a good idea apparently... unless you get a new motherboard.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...