Jump to content
Corsair Community

RIP hx1000 ;(


Recommended Posts

I'm having the same issues with my HX1000. It just suddenly refused to turn on. On first power-on attempt all fans flickered for a half second and then nothing happened :(: I tested PSU in another system - all the same. Also I unpluged psu from PC an tried to turn it on by attaching only one 120mm fan and shorting green-black 24pin connector wires - again fan just flickered for moment and that's it. I also used Digital multimeter to measure 4pin molex voltage - at the first power-on attempt it showed 10.8 volts and instantly started to drop 8.6 then 6.5 then 4.3 and all the way to zero in a 3-5 seconds. After several unsuccessful power-on attempts I smelt electrical burning... R.I.P. my friend :(:

I live in Latvia (Eastern Europe). I bought HX1000 in local PC shop. I know they get their PC components from local Distributor (GNT Latvia) which is listed in Your webpage as Corsair-authorized Distributor. Unfortunately I have quite bad experience with Latvian distributors - I had to wait a month after they finally managed my motherboard RMA process. So I'm wondering is it possible to send the PSU directly to Corsair RMA service (to Netherlands in my case)? I know that the Distributor has only several Corsair WX550 and TX650 PSU's but definitely no HX1000 in stock. I bought HX1000 in august 12th 2008. All I have is my local PC shop warranty paper. It would be very nice if I could send the psu directly to You without having headache with Latvian distributor RMA process.

Please excuse me for my english...

Link to comment
Share on other sites

Thanks for reply ;): I allready made RMA request and sent well packaged (tons of bubble wrap :D: ) bare PSU this morning via local post service. The shippment price as expected was quite high - 28 Euro :mad: Nevertheless it's worth it - I better pay extra for getting replacement in few days than wait couple weeks on my local distributor's so called "customer service". Hope to receive my power horse in ~10 days (main rig looks sad :D: without HX1000). I'll post my RMA progress as soon as I get an update ;): Btw it's my first Corsair RMA experience, so far it's excellent :):
Link to comment
Share on other sites

Hmm :sigh!: I shipped package 10 days ago on 09.05.2009. Still haven't got RMA status update. Parcel service stated 3-4 day delivery time so I believe my PSU should be in Netherlands by now. I used local postal service which doesn't provide package tracking, package is insured. I already sent e-mail to Corsair rmaservice. I just hope my package isn't lost :bigeyes:

RMA #1105734

Case #963292

Link to comment
Share on other sites

  • 2 weeks later...
Today received brand new HX1000 from Netherlands RMA depot :biggrin: They sent completely new retail PSU package :eek: - now I have 1,5 HX1000s :D: Thank You so much Corsair for pleasant RMA process :praise:
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...