Jump to content
Corsair Community

Survivor 8gb problems: Undetected, corrupted?


xtr0y3re

Recommended Posts

I have an 8gb Survivor, however due to my lack of patience, I recently pulled it out of my laptop (Vista 32 Pavilion DV-5) while it was copying files. I tried then to put it back in, and it would not show up in "My Computer". "My Computer" would then proceed to crash. I tried to format using Disk Management, but that also froze, and tried using HP's Disk Utility tool and that froze as well. The weird thing is, that it does appear in "My Computer" after a good few minutes, but one click and it would freeze, then when i try to right click, the menu opens up a few minutes later. Lastly, one attempt went through, but access was denied to change the owner of the drive, and I could not format as that was restricted from me as well. I have full Account Privileges, although I will check, and I will update this post.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...