Jump to content
Corsair Community

USB Device Not Recognized / A problem occurred during hardware installation.


bobthebuilder

Recommended Posts

I just got a Corsair 64GB flash drive. Straight out of the box I started having problems with it. When I first connected it, everything went as it normally would - New hardware detected... and some automatic process that involved installing drivers or reformatting the drive, I don't remember. Only after that part was done and when the computer asked me to restart the computer is when everything went terribly wrong. To be honest, I can't recall whether I removed the flash drive before I restarted or if I left it in the USB port.

 

Anyways, after the computer rebooted, I went to test out the drive. I added about 340 MB worth of pictures. But when I checked out the used space in My Computer, the pie chart indicated that all the space was occupied. So I opened up the drive and all the files were there along with 2 odd-looking folders with encrypted names (those 2 folders weren't there before). When I clicked DELETE to erase the images, nothing would happen. There would be no error message, just nothing happened, and the pictures were still there. Then I tried deleting the 2 folders, and I'd get the familiar error that it was write-protected.

 

At that point I suspected that I may have made a mistake in the beginning before the system restart. So I tried to reformat the drive by right-clicking in My Computer, selecting FAT format. After clicking start, the format wouldn't even begin, like I was clicking a dead button. So I looked through the internet and one page suggested using the program "HP USB Disk Storage Format Tool" for formatting Corsair 64GB flash drives. I did that with the FAT default selected. Just as the progress bar reached the end, it was interrupted by some message that the format failed. I took a look at the memory chart in My Computer and the capacity was no longer listed as 64GB as before, but was now halved to 32GB.

 

Searching through Google, a web page mentioned how FAT systems are normally 32GB, anything above that was read in NTFS format. So I used the same program only this time NTFS selected. The result was the same...error at the end of the progress bar. From then on, I would keep getting the following two balloon popups: 1) USB Device Not Recognized, 2) A problem occurred during hardware installation. Your new hardware might not work properly." Now it's missing from the My Computer page. In Devices Manager the drive is listed as an Unknown Device.

 

I uninstalled the driver, re-inserted the drive, but to no avail. The automated driver/format process I had in the beginning is now absent. Now what I'm only getting is the 2 yellow error messages above the taskbar. All the other pen drives I have work except for the Corsair.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...