Jump to content
Corsair Community

Bad Pinout on TX750


monofurioso

Recommended Posts

I just received my TX750 PSU today, from Newegg. I was almost finished with my PC build when I suddenly realized the pinout on the EPS/ATX12V 8-4 pin cable was all wrong. :(

 

Here's the pic:

Edit: sorry, Picasa web albums aren't direct link friendly. The pic is here:

http://picasaweb.google.com/lh/photo/2gGGD2Jv9z59Bq4zw2PmlA?feat=directlink

 

2 of those 4 connectors on the right are supposed to be squared. They're all rounded. Ugh. Now to try for an RMA. Such a weird problem, has anyone seen anything like this before?

Link to comment
Share on other sites

Circles can fit in squares. Also, the shapes have nothing to do with the pinout. Your pic doesn't show up either.

 

 

Sorry, yeah, I realize pinout has little to do with the shape of the connector interface, I just didn't know how best to describe it. I fixed the link above to point to the image.

Link to comment
Share on other sites

Check the MB you have for what pins are +12 Volts and what are ground but if the MB takes an 8 Pin 12 Volt plug it should fit, have you tried to plug it in?

 

I suppose that the rounded connectors will fit in a square hole, just not vice versa. I'm pretty gun shy about plugging it in since the connectors don't match and the PSU connector doesn't match the image of it on the Corsair product description page.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...