Jump to content
Corsair Community

Flash Voyager 32GB problems


Recommended Posts

Yo.

 

After using my Flash Voyager 4GB for so long, i decided i would buy another but with much more space, especially for my college work. So just after Christmas i bought the 32GB Flash Voyager. The problem started when i used the flash drive in a mac. After i had transfered some JPEG files from a mac, i then tried to use it on my home computer and for some reason the flash drive was not reconised. Well, i say not reconised, my conputer registered that something had been plugged into the USB port, but it couldnt figure out that it was my Flash Voyager.

 

After talking to my friend who is a computer engineer, he told me about how it was possible that using the flash drive in a mac, may have re formatted it in a way so that XP couldn't reconise it. He advised me to take it back to the mac and format it so that it would work for both. Yet when i tried this, the mac also did not reconise it, and it seems to have just died :eek: and isnt reconised at all by any system anymore.

 

I wouldnt really be so concerned, but it had a fair amount of files that i had been using recently, and hadnt had a chance to backup. Therefore i will have to spend some time re-doing my work, which i'm happy to do, but is still a bit of a hassle.

 

I'm just wondering what i should do with it now... any suggestions or help would be greately appreciated.

 

Thanks :):

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...