Jump to content
Corsair Community

Flash Voyager 64gb won't format - unusable


controllore

Recommended Posts

Hello,

 

Yesterday I bought one of those flash mems and as soon as I got it I saved a couple of files on it to be copied on another pc (both files around 500mb).

The pc where I copied the files from is a Vista Ultimate 64 bit. The one were I wanted to copy the files to is a Windows XP Pro (x86).

 

The copy operation was error-free, but when I inserted the pen in the second pc and browsed it I could see one of the 2 files with its name garbled, the characters were not unicode. I couldn't delete it.

Tried to insert it back on the source pc and still the same garbled file.

 

So I tried to reformat the pen but I wasn't able to, since both Vista and XP failed trying to format the flash memory. By the way, I had to use the disk management tool because using the contextual menu to format it shown no possible type of file system and no allocation unit size options. Clicking on "format" simply did nothing.

 

The Disk management tool kept failing after going to the full 100% of the operation (full format, not the quick one)

 

Then I tried with Linux (gParted) to delete the partition and recreate it. This operation succeded but when I tried to format, it failed again (I tried ntfs, fat32 and ext2 - always the same error).

 

I run out of possible tools/ideas to try to format the flash memory... It is simply in its unchangeable state of "unformatted" and unusable. I couldn't even manage to use it one single time...

 

Do you have any suggestion before I use it as a toy for my cat?

 

P.S.

I also tried the Panasonic SD Formatter 2.0, but it doesn't recognize the pen.

Link to comment
Share on other sites

  • Corsair Employees

Please try the Format procedure listed here, and the directions are on that site with an explanation of the fat file system and why this may have happened.

 

If you still have problems we can get it or them replaced, please use the RMA request found in TSXpress or follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it!

Link to comment
Share on other sites

Unfortunately it still has problems. After a couple of days of tests I found that once in a while a copied file is scrambled. It happens with any kind of file, of any size (up to the 2gb fat32 limit, of course).

 

Text files are scrambled and contain an unreadable mess, video files are unplayable, compressed archives give a crc error.

 

So it seems that it has some serious problems after all. I tried to reformat it with the fat23format utility and it did the job, but the behaviour of the flash memory was then the same.

 

By the way, I needed to format it in NTFS fs but it's not possible, it keeps failing the operation and then I have to reformat it with fat32format before seeing it as formatted again.

 

Alas I think I'll have to have the pen replaced...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...