Jump to content
Corsair Community

P5B, 4GB RAM not booting to XP 64


V15b

Recommended Posts

Hi

 

I recently built a new pc (specs are in my profile). With this, I bought 4GB of RAM (2 sticks of CM2X2048-6400C5). I intended to run this under XP 32 bit, acknowledging that I would only see ~3.2GB of RAM.

 

In bios, with "memory remap" (MR) disabled, I see only 2GB RAM, and with MR enabled, I see 4GB of RAM.

 

In XP 32, with MR disabled, I see 2GB RAM (minus a bit for gfx cards etc).

 

In XP 32, with MR enabled, I see 2GB RAM

 

In XP 64, with MR disabled, I see 2GB RAM

 

In XP 64, with MR enabled, XP64 will not boot.

 

I have tried putting each stick of RAM in seperately and booting, and I get no problems, so I don't think that I have a faulty stick.

 

I have tried to install a clean XP 64 install with MR enabled, and the install process crashes at the "Setup is now loading windows" stage

 

I have updated the bios to the most recent version.

 

I have increased the RAM voltage to 2.1V, and the Write delay (i think - it was a tip from here somewhere!) to 15 (from 10).

 

I tried enabling MR with a single stick of RAM - it did not like this, and bios would not load.

 

Does anyone else have any ideas? This is driving me insane now!

 

Thanks a lot

 

V

Link to comment
Share on other sites

Thanks for your reply, RAM GUY.

 

I have indeed got SP3 installed (and SP2 on XP 64, since there isn't an SP3 yet)

 

I have got in touch with asus, and they have helped me to upgrade the bios, and clear CMOS and a few other tweaks, but they seem to be running out of ideas now too (their last advice was to try different RAM, which is fine, but expensive!)

Link to comment
Share on other sites

I have installed more than a few P5B mainboards and they have a strange anomaly. With a 32bit OS and 4GB installed, you must disable Memory Remap to gain the 3GB. With a 64bit OS and 4GB installed you must enable Memory Remap to gain the 4GB. I installed a dual boot system with XP-32 and Vista-64 and the only way to get maximum memory in both systems was to disable remap when booting into XP and enabling remap when booting into Vista-64.

 

If your system will not boot with Remap enabled I would contact ASUS and DEMAND an RMA for a NON WORKING board (MEMORY REMAP FUNCTION) with > 3GB. Clearly the Memory Hole is NOT being remapped. You may even have a bad memory slot. Test each slot singly with one stick. Remove that stick and test each slot singly with the other stick.

 

The reason for my caps is because ASUS should know this and should not attempt to create more trouble for you in testing and running around. Be firm with them!

Link to comment
Share on other sites

  • 3 weeks later...

Thanks to you both for posting.

 

I sent the motherboard back to asus (via ebuyer). they didnt have any to do a direct replacement, so I got an msi p43 neo instead. Plugged everything in, booted up, and voila, 2GB RAM in XP32 and 4GB RAM in XP64 - nice and easy!

 

So, it was indeed a faulty motherboard causing it all!

 

Thanks again

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...