Jump to content
Corsair Community

PC2-8500 will only run as PC2-6400...


Serenity

Recommended Posts

I installed 2x2GB of the Corsair Dominator RAM (PC2-8500 C5, 1066 MHz) in my ASUS M3A78-T motherboard. Upon using CPU-Z, it reports that my RAM is only operating at PC2-6400. The part number is CM2X2048-8500C5D.

 

It is my understanding that my system information is accessible from when I registered. If not, I'll kindly post anything I can to help.

Link to comment
Share on other sites

DRAM frequency is 401 MHz.

 

How would I go about manually setting the frequency? I haven't seen anything in the BIOS on the subject; I just updated it this AM.

 

When I installed the RAM I simply popped the DIMMs in as per the instructions. I wouldn't even know anything was off/wrong without CPU-Z.

Link to comment
Share on other sites

  • Corsair Employees
Since you bought memory that runs faster than stock memory, you will need to manually set the frequency in the BIOS. Please consult your manual and look in the BIOS section. It will explain how to change the memory timings and the memory voltage to run your memory at 1066.
Link to comment
Share on other sites

I dug deeper into the BIOS options. I didn't see an option for 1066, but there was one for 1067. Thinking about how some CPUs vary in spite of what's on the box, I thought this may have applied to RAM. Checked that option, put the RAM into ganged mode & rebooted. CPU-Z now reports 534.7 MHz.

 

The SPD tab still says the RAM tops out at PC2-6400 (400 Mhz).

Link to comment
Share on other sites

SPD is a read only documented set of tables so that operating systems can read the values and insert them at "Auto" to allow for a system to boot.

 

As well, 533Mhz in CPU-z is 533 X 2 (Double Data Rate) = 1066Mhz. You are where you should be.

 

I dug deeper into the BIOS options. I didn't see an option for 1066, but there was one for 1067. Thinking about how some CPUs vary in spite of what's on the box, I thought this may have applied to RAM. Checked that option, put the RAM into ganged mode & rebooted. CPU-Z now reports 534.7 MHz.

 

The SPD tab still says the RAM tops out at PC2-6400 (400 Mhz).

Link to comment
Share on other sites

SPD (Serial Presence Detect) and JEDEC (Joint Electron Device Engineering Council) are the reasons why they do not default to the high end DRAM of the package.

 

Simply put, the JEDEC standards apply to standardization for memory subsystems in computers. This is so there is a default to standard settings and of which JEDEC specifies. At the moment, the highest standard as of June 2007 is 1333Mhz and 1.5v and computer systems BIOS's as well as DRAM modules comply with these standards for plug and play interface. Without these standards and applications to standards there would be no successful boot. So, the system boots to the JEDEC standards ROM Burned into the SPD settings report of the DRAM modules through a plug and play interface.

 

Then, you must either enter the values manually, or set to the XMP (Extreme Memory Profiles) Intel / (Enhanced Performance Profiles) Nvidia

 

Research:

 

JEDEC

http://www.jedec.org/

 

SPD

http://www.simmtester.com/page/news/showpubnews.asp?num=101

 

XMP

http://www.intel.com/assets/pdf/whitepaper/319124.pdf

 

EPP

http://www.sudhian.com/index.php?/articles/show/sli_ready_memory_enhanced_performance_profiles_overview/sli-ready-epp_memory_in_use

 

 

 

Sounds good. Troubleshooting has been fun. But why wouldn't it default to what was on the package? Probably something to do with ASUS...
Link to comment
Share on other sites

Heh, the more you know, right? Thank you.

 

Idk if it's related, but the first time I tried FEAR 2 w/ the new settings, the game caused a BSOD. Thing is, it leaves the screen so fast, who could ever read what it said? Is there any way to slow that down? To be on the safe side, I set my RAM for 800 MHz - game seems fine now.

Link to comment
Share on other sites

Set your system to show a blue screen and halt at the blue screen. This will give you information.

 

Control Panel --> System Properties --> Advanced --> Settings for Startup and Recovery --> Settings --> System Failure --> Uncheck "Automatically Restart" and then set the drop down box to show "Small memory Dump (64KB)

 

Have you set the DRAM voltage to 2.1v? If so then, I would just set your system to run with 800Mhz and set the timings tighter. It's better for Phenoms anyway. More stable and as fast. Set the timings to 4-4-4-12 and 800Mhz.

 

Heh, the more you know, right? Thank you.

 

Idk if it's related, but the first time I tried FEAR 2 w/ the new settings, the game caused a BSOD. Thing is, it leaves the screen so fast, who could ever read what it said? Is there any way to slow that down? To be on the safe side, I set my RAM for 800 MHz - game seems fine now.

Link to comment
Share on other sites

Since you bought memory that runs faster than stock memory, you will need to manually set the frequency in the BIOS. Please consult your manual and look in the BIOS section. It will explain how to change the memory timings and the memory voltage to run your memory at 1066.

 

Unfortunately with recent BIOS updates the manual has become nearly useless. I have the same motherboard and RAM kits for my system, and now that I've upgraded to the Phenom II 940 my system is experiencing total hard locks. I've tried reducing to one kit but the stability persists and gets worse if I manually configure this RAM as suggested. Maybe I've missed some setting since they changed the BIOS around.

Link to comment
Share on other sites

I think I may have beaten you to it. A few hours ago I figured out how to change my timings and voltage. I'm fairly certain the BSOD was caused by my setting the frequency to 1067MHz without changing the timings or the voltage. Now that I have made the changes, everything seems smooth, maybe even a little bit peppier (in my head...?).

 

If instability does occur, I'll give those timings a shot.

 

I have been wondering about the BSOD restart behavior for awhile; thanks again.

Link to comment
Share on other sites

Unfortunately with recent BIOS updates the manual has become nearly useless. I have the same motherboard and RAM kits for my system, and now that I've upgraded to the Phenom II 940 my system is experiencing total hard locks. I've tried reducing to one kit but the stability persists and gets worse if I manually configure this RAM as suggested. Maybe I've missed some setting since they changed the BIOS around.

 

I'm waiting on the 940 for now (price drop; Windows 7?) but I am running the latest available BIOS update, dated sometime in January. The manual was useless for things like the CL, tRCD, etc. and how they fit in with the settings for DCT0 & DCT1. I'm only running the two sticks (1 kit?) and only altered settings in DCT0 (I think); I'll need a moment to look again at what I changed.

 

Of course, if you already way ahead of me, please disregard, lol. :roll:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...