Jump to content
Corsair Community

Transfer speeds ok, LONG pause at end of each file


murphymurph

Recommended Posts

I recently purchased a 16gig survivor. Beautiful drive but until recently i haven't tried to copy anything large to it.

 

Decided to take some larger media files to my friends house and it appeared to take FOREVER to transfer files. After some additional troubleshooting i found that it's not the transfer rate per say, but that there seems to be a long pause at the end of each file.

 

A LONG pause causeing what should be a couple minute transfer to take 10-20minutes (if i'm copying say 10-20 files)

 

Any idea what would cause this? I've done some diagnostics on the flash drive itself, it seems to be ok. Reformatted a couple times....

 

I dont believe this to be a vista issue as i tried this on an older pc w/ xp32 and it seems to perform at about the same speed.

 

Thanks for reading and thanks ahead for the replies!

Link to comment
Share on other sites

  • Corsair Employees

Actually that is a Vista issue I think it was supposed to addressed with SP1 but I have heard others reporting the same type of issue with Vista.

 

I would check this link as it seems to be a common issue with Vista

 

This seems to work as well.

Go to Local Disk ©, got to Windows, got to System32, go to Driverstore, go to Filerepository, go to usbstor.inf ( click the on that is newest), copy the usbstor.inf and usbstor.PNF files. After you have copied the two files got to Windows, inf folder and paste the files in that folder. Now your usb devices (flash drives, hard drives, ipods, etc.) should work. But you may need to remove the listed device for the non functioning device and restart the system.

Link to comment
Share on other sites

hey thanks for the reply!

 

i checked out the link and tried their suggestions / suggestions in your post.

 

the files were present already but i copied them anyways. no change.

 

like i said i doubt it is a vista issue as i'm seeing the exact same performance on my xp system

 

any other ideas ?

should i be formatting using anything other than an allocation unit size of 4096 (doubt that would have anything to do with it)

 

it is possible there is some firmware on the usb device itself?? (i'm no hardware guru so don't laugh if that doesn't even exist)

 

i'll try anything at this point.

 

it's very important to include that smaller files copy in the blink of an eye. but once i start getting into the couple hundred meg range it all falls apart

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...