Jump to content
Corsair Community

HX620 problem


seekeroftruth

Recommended Posts

Hello, Thank you in advance for any help, from what I've seen you all have great customer service.

I have had this PSU for about a year, and it has been running fine. Last night I reorginized my computer and ended up using different molex ports on the PSU. Everything looked good and when I attempted to start the compuer there was some kind of short and the system ended up smoking. So I inspected everything and there was no visible evidence of damage or any reason for the short(everything plugged in correctly, no loose screws etc) So I tried again and it still didnt want to start.

Finally I moved the GPU to the lower molex, and the other peripherals to the top 3 molex ports and everything is running fine.

Is it possible that there is a internal problem for the top GPU or lower molex connection points? if there was a connection problem would it short/smoke without losing the functionality of the original ports I am using now?

I am a little confused because I thought for sure my whole system was toasted :s

My specs if needed:

Link to comment
Share on other sites

  • Corsair Employees

If you have isolated a port on the PSU which is causing problems, or if the PSU had smoke coming from it at all, then we would want to get the unit replaced!

 

Please use the On Line RMA Request Form and we will be happy to replace it. Be sure to check the box that says “I've already spoken to Technical Support and/or RAM Guy.”

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...