Jump to content
Corsair Community

Ram issue, motherboard issue or user issue


Ramjet

Recommended Posts

Hi guys,

 

Firstly thanks for creating such a great forum. From what I've seen excellent advice and resources for testing and diagnostics ;):

 

I built a new system recently (specs hopefully below, Bios is the new 1901), the only change from my original request was that they replaced the 2x2GB sticks I had ordered with the 4x1GB sticks shown, telling me I would get the same result - just in a different way.

 

Having finally built my machine it worked for about a week before developing numerous intermittant Blue Screen of Death crashes, most often saying IRQL_Not_Less_Than_Or_Equal_To but also a whole host of others. I managed to troubleshoot various windows issues using event viewer but eventually the system became increasingly unusable. I did much research online and eventually removed 2 of the sticks of RAM and ended up with a stable system.

 

I have finally had time to go back and look at the issue again, downloading and running Memtest86+ on each stick and slot etc. However, I'm unable to diagnose the issue properly and hope you can assist me. Apologies for length.

---------------------

Firstly I tested all 4 sticks in the first RAM slot using 5-5-5-15-2T at 2.1v and 1066, and all passed okay.

 

Secondly I tested a single stick in all 4 slots using the same settings, ending up with 111 errors on my first pass on slot 2, with all 3 other slots being fine.

 

I thought I had solved the problem (a bad ram slot) but then retested using default settings and it passed... :confused:

 

I then put all the ram back in and tested at defaults and ended up with 8 errors.

 

I retested using 5-5-5-15-2T with all 4 sticks and they all passed. I jumped into windows and used it for awhile but the next day the PC wouldn't boot into windows (which is what was happening when the PC first started developing issues), giving me thousands and thousands of errors when I started retesting.

 

I rebooted, retested using defaults on all 4 sticks and memtest86+ itself crashed. I managed to get back into the system using the two sticks at default settings.

 

In summary, I think I have either a bad board or some bad memory, but I'm not sure which. I would really like to get my 4GB working as I notice the difference as I am a heavy gamer and have Vista 64. Any help would be greatly appreciated. Cheers.

Link to comment
Share on other sites

  • Corsair Employees
With 4 modules I would suggest setting the memory frequency at DDR667 or DDR800 and set the memory Voltage to 2.1 Volts and set the NB/MCH/SPP Voltage to +.2 Volts as well and test the system with http://www.memtest.org. In addition, with some MB's (Mostly ASUS) you have to disable legacy USB in the bios when running any memory test.
Link to comment
Share on other sites

Great, thanks for the quick reply RAM GUY.

 

I'll try those settings tonight and see how it goes. I am using the Memtest86+ from http://www.memtest.org but will double-check that Legacy support is disabled as suggested. I'm fairly confident that it was disabled for the first round of testing but would have reverted to enabled when I went back to defaults.

 

Thanks again.

Link to comment
Share on other sites

Okay, back with the suggested test results.

 

I put all 4 sticks back in the system, set the bios to default settings and then made the following changes:

Mem: 2.1v, NB: 1.4v (looks like 1.2v is standard); DDR: 667, Timing: Auto (5-5-5-18-2T), Legacy USB: Disabled.

 

I managed a full pass without any errors. Then, in an attempt to recreate the instablity I had experienced earlier (logging back into windows after a period of relative stablity) I loaded Windows, updated my Windows Experience Score to test the system (5.9 all round but RAM showed only 5.1). I then logged off and managed to load windows a second time, again getting a score of 5.1.

 

For the second test I simply changed the memory frequency to 800. Again, no errors were reported from the pass. Windows score updated to 5.9 all round except RAM which moved up to 5.3. Again, reloading Windows again and retesting my score didn't cause me any issues. Out of interest I looked at the NB temperature in the Bios and it is showing 66 (it's been quite a hot day so the room is probably at least 26 at the moment).

 

Great, so with a little guidance (ie, increasing NB power) it looks like the problem has been solved :biggrin:

 

As it looks like it's not a RAM issue I'm happy if you want to move this to the over-clocking forum as I do have a few final questions, however:

- when you say up the NB/MCH/SPP I take it you mean either of these? I could only find the NB one to change

- I'm fairly sure my scores were higher running with 2 sticks at 1066. Stupid question but is more RAM better or is faster better (ie, should I being use 2 @ 1066 or 4 sticks @ 800)?

- should I be upset that I ended up with 4x1GB sticks? Besides the obvious limitation on upgrading down the track, it seems that I would have been able to run 2x2GB sticks at 1066 and therefore would have had a better result.

- is there anything else you can suggest to get more out of the 4 sticks I do have? I understand many small incremental changes may be required to work out the threshold before I hit instability again.

 

Anyway, many thanks for the quick, quality advice so far.

Link to comment
Share on other sites

Well unfortunately my old problem hasn't yet gone away (at least not at 800 speeds). I turned the PC on today after getting home with the settings unchanged from last night (Mem: 2.1v, NB: 1.4v; DDR: 800, Timing: Auto (5-5-5-18-2T), Legacy USB: Disabled) and it stubbornly refused to start, or even allow me to enter the BIOS. The LCD Poster showed a variety of issues (firstly TESTVRAM, USBINIT, MSINSTAL, DETIDE, ENSETUP, PCIIRQ and ERRORMSG) as I retried repeatedly to get into the bios setup, steadily removing all the peripherals I could (mouse, network cable and USB stick).

 

Resisting the urge to take out 2 sticks of RAM (which is what I had done in the past to solve the problem) I finally resorted to turning the machine off, unplugging it and pressing CLR CMOS on the back of the box.

 

I finally got into the Bios Setup, reset defaults then entered in Mem: 2.1v, NB: 1.4v; DDR: 800, Timing: Auto (5-5-5-18-2T), Legacy USB: Disabled, Plug & Play: Yes: Primary display: PCI-E, as the error messages had talked about VRAM and had also given different error messages as I took out some of the USB devices (usb drive and mouse). I then tried testing the memory but Memtest86+ itself failed to start properly.

 

Getting back into the Bios again I changed the DDR back down to 666.7, leaving the rest as described. The machine booted and loaded Windows successfully, giving an experience score of 5.3. I then ran the Memtest86+ which passed successfully.

 

I'm afraid I'm still lost :confused: Last night the machine passed at 800 and worked fine for hours on end, including streaming YouTube videos. Like other times, however, the next day the machine simply refused to start, requiring a considerable effort to get back up and running. Lowering the speed of the RAM to 667 has helped make the machine stable but I really feel like I'm having to handicap the system just to make it work at this stage.

 

Any more help would be gratefully appreciated. I'm going to be away for a few days but will make any suggested changes when I return and give you another update. Cheers.

Link to comment
Share on other sites

Okay, back on the issue and I'm afraid things have gone from bad to worse. After using the machine all night I decided to perform a quick test before I went away, turning on the machine on to see how it was going.

 

All the settings were unchanged from the night before (Mem: 2.1v, NB: 1.4v; DDR: 667, Timing: Auto (5-5-5-18-2T), Legacy USB: Disabled) and once again massive trouble getting the machine to boot, including Test VRAM and Test Mem issues. I finally gave up and removed two of the sticks and the machine was back up and running.

 

Now that I'm back I have reset the Bios again and tried two sticks at (Mem: 2.1v, NB: Auto; DDR: 1066, Timing: Auto (5-5-5-18-2T), Legacy USB: Disabled) making a single Memtest pass okay and giving a score of 5.5.

 

It's all very strange - almost like the machine breaks itself overnight. Does the RAM have to clear itself or something? It's very strange as I can seemingly reboot alright during a session, it's only the next day that issues seem to arise.

 

It's looking like the computer shops recommendation to change the RAM I originally ordered (2x2GB sticks)for 4x1GB sticks has been a disaster. That said I believe I should be able to get all 4 up and running so will keep testing.

 

I'll test each stick again as suggested, and will use the Mem: 2.1v, NB: Auto; DDR: 1066, Timing: Auto (5-5-5-18-2T), Legacy USB: Disabled. I'll then test a single stick in each slot again.

 

Cheers

Link to comment
Share on other sites

Okay, back with the latest round of testing, but still need some help in determining the exact cause of the problem.

 

Firstly I tested all 4 sticks in slot 1 using Mem: 2.1v, NB: Auto; DDR: 1066, Timing: 5-5-5-15-2T, Legacy USB: Disabled (Note that the default timing was 5-7-7-24-2T which surprised me as it was only for a single stick).

 

Sticks 1 and 2 had no trouble at all. Stick 3 had massive errors but I reseated the ram and the retest was fine. I missed the boot option on stick 4 and it froze on the green vista bar, but memtested fine with 2 passes.

 

I then tried the slots again. Firstly Stick 4 in slot 2 where it froze on test 4. I rebooted and retested. The second test passed okay but then it froze on test 4 again on the second pass. Stick 4 then passed 2 passes in slot 3 but froze on test 4 once again after reporting errors. This looks like the likely problem (ie, my slots 2 and 4 - which are only used when I have more than 2 sticks installed).

 

To prove it I tested Stick 1 in Slot 4 and ended up with thousands of errors and a freeze on test 3. Sticks 1 and 2 also failed in slot 2 with hundreds of errors over two passes.

 

Finally, I tried resetting defaults again (except disabling legacy USB support) with Stick 2 still in slot 2. Amazingly it passed 6 times without a fail. I rebooted (trying to recreate the intermittant nature of failure) but, today at least, it passed 2 more times without an issue. I also tried stick 2 in slot 4 with the same settings and it passed 7 times okay.

 

So, it looks like my board has issues running the ram at stock speeds with slots 2 and 4 but frustratingly it will pass the test with just 1 stick at defaults. Any more suggestions or is it simply time to get the board replaced/replace the ram with the 2x2GB I originally wanted? Cheers

Link to comment
Share on other sites

  • 2 weeks later...

Hi there,

 

Just a quick update on this to close it out. I finally ended up taking the machine back to the retailer I bought the parts off, together with a link to this thread. I'm very pleased to report that a week later I have a rebuilt machine with a replacement motherboard and all 4 sticks of RAM currently working.

 

The difference in performance is great, the machine just seems that much more switched on in Vista with the full 4GB, even at the current BIOS defaults! Strangely enough the Windows experience score is only 5.3 but from an end user perspective as I say it seems much better than what I had before.

 

Given the intermittant nature of the problem I'll obviously continue to monitor the system but are very hopeful the machine will now be stable. If I can get it stable at defaults I may eventually be able to try updating the RAM settings per your original advice. For now at least, defaults are a big improvement!

 

Thanks again for all your work in helping me diagnose the issue, it certainly made the case for replacement much more compelling having completed all the testing.

 

Best regards,

Ramjet

Link to comment
Share on other sites

  • Corsair Employees

I have posted this previously about running 4 modules and the score in Windows Vista does not represent a performance Mark.I would suggest running Sy-soft or Eeverest Home to compare the configuration.

 

With 4 modules I would suggest setting the memory frequency at DDR667 or DDR800 and set the memory Voltage to 2.1 Volts and set the NB/MCH/SPP Voltage to +.2 Volts as well and test the system with http://www.memtest.org. In addition, with some MB's (Mostly ASUS) you have to disable legacy USB in the bios when running any memory test.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...