Jump to content
Corsair Community

recognized as removable storage drive


IJL99

Recommended Posts

My Voyager has been recognized as Corsair for a few months until today. I loaded my first music onto it, took it to another computer, where it has always worked before and it was not recognized as Corsair but came up as removable storage. It shows 0 mg available and 0 mg used. Does this mean that the disk has been wiped clean or just not recognized an Corsair anymore? NO matter where I put it, it now registers the exact same-removable storage.
Link to comment
Share on other sites

I am having the same problem. have had the 64GB Corsair for a while and it has worked great. Now when I plug it in it shows up as Removable Disk - not recognized as Corsair.

 

I have read the other forms and downloaded the fat32format. - it fails with the following message:

Failed to get Device geometry

GetLastError()=21: The Device is not ready

 

I also tried running the sdfv2000.exe utility described in another post but it does not recognize the device.

 

Using Disk Management - it shows up as Removable (G:) with No Media in the discriptor.

 

If the system is seeing this device as a drive containing removable media - How can it be reformated .....??

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...