Jump to content
Corsair Community

TX750W Odor


DBwmn

Recommended Posts

My recently purchased TX750W is mounted right side up at the bottom of my case. There is about 1/4 inch clearance between the PSU and the bottom of the case. Overall case air flow is decent as are ambient temperatures - 30C to 34C depending upon the utility. The PSU has not seemed hot when touched.

 

For the last 2 days the PSU seems to be emitting a very strong odor, not a burning smell, but a strong "new electronic" smell that permeates the level of the house and has been giving me headaches.

 

Is this normal for a new TX750W? Given the position that the PSU is mounted, could it be getting too little air flow? Could this issue be resolved by mounting this PSU upside down?

Link to comment
Share on other sites

A couple of times I've had a new build emit a noticeable smell when powered up for the first day or so, but it disappeared slowly after a few days use. However, it was never so strong that it made me feel ill though. Even if it doesn't really seem to be a heat problem, you could try turning the PSU upside-down to see if anything changes, the unit will work just as well any way it faces.
Link to comment
Share on other sites

  • Corsair Employees

I don't think that the orientation of the PSU will make much of a difference. Sometimes you can get a PSU that will give off an "electronic" smell, but usually it will go away after a few days. I would give it about a week and if its still there then lets get it replaced! Of course if the smell is so bad that its making you feel ill, then lets just get it replaced now.

 

You can use the On Line RMA Request Form and we will be happy to replace it. Be sure to check the box that says “I've already spoken to Technical Support and/or RAM Guy.”

Link to comment
Share on other sites

Thank you for the tone and promptness of your reply. As suggested, I gave the power supply a week. The odor is still evident though not as strong and pervasive. Should I need to, I can still exchange the PSU at the brick and mortar vendor from whom I purchased it.
Link to comment
Share on other sites

A couple of times I've had a new build emit a noticeable smell when powered up for the first day or so, but it disappeared slowly after a few days use. However, it was never so strong that it made me feel ill though. Even if it doesn't really seem to be a heat problem, you could try turning the PSU upside-down to see if anything changes, the unit will work just as well any way it faces.

Turning the PSU upside down seemed to improve things. Perhaps this smell is simply the "nature of the beast," in this case the beast being new computer components.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...