Jump to content
Corsair Community

Weird noise and arcing


evensis

Recommended Posts

Purchased a Corsair TX650 a couple of months back, has run fine apart from a few weird issues. Whenever my gtx280 becomes under load there is a strange high pitched noise coming from the PSU. I originally thought this was the graphics card but on closer inspection it is actually coming from the PSU itself. I've also noticed a degradation of performance, specifically in flight sim x. Albeit this could be a driver issue!

 

Another issue, is when hitting the power switch on the back i hear a loud popping after leaving it switched off for a minute or so.. I attempted to recreate the issue, and after a try of leaving the PSU off for a minute, and just looking at the underside and switching it on. There is an electrical arc going between components, which is slightly disconcerting with the ramifications of a nice electrical fire.

 

Are these issues normal, or would an RMA be in order?

 

Thanks for the help!

Link to comment
Share on other sites

I have gone through two replacement psu's with the same problem (when hitting the power switch on the back i hear a loud popping sound plus the arcing you spoke about) Also i have gone through this forum looking at older posts and found a number of other people had this same problem. Thank god for the 5 year warrenty is all i can say.
Link to comment
Share on other sites

  • Corsair Employees
I'm not the only one then! Gotten to the point where I won't touch the power switch, but use a rubber coated screwdriver to push the button instead lol.

 

Let's get it replaced, please use the On Line RMA Request Form and we will be happy to replace it. Be sure to check the box that says “I've already spoken to Technical Support and/or RAM Guy.”

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...