Jump to content
Corsair Community

Is my TX650 PSU faulty or incompatible?


Warrior Monk

Recommended Posts

I've been having quite a few problems since installing several new pieces of hardware.

The first, two sticks of RAM didn't give me too much trouble.

Second i installed a corsair TX650 PSU and got that working ok after some trouble.

Third i installed a GTX 260 and it was working as well for awhile, about a day.

 

My HD was clearly infected with a virus so i went about saving the data i wanted before formatting it. During the saving of data my system would reboot and half the time i couldnt boot up... the HD name would be scrambled or non existant.

After messing around with the IDE cables i could sometimes get it to work again, long enough to save all the data i needed.

 

After this started happening, whenever i shut down my system, it wouldn't power up again unless i either turned the switch off and on, or unplugged and plugged it back in. It has been like this since.

 

The HD name in BIOS has been garbled or not detected as well, and since trying out new IDE cables my system wont boot at all now.

On startup, i get a long beep every 5 seconds which is the same sound i heard that was fixed by switching the RAM around. Nothing i do now though seems to work.

 

So whats going on? Is my HD failing? power supply faulty or just incompatible with my Motherboard? Is my motherboard broken? All of these?

 

My motherboard is a C51GM-M by Elitegroup.

Link to comment
Share on other sites

I wrote up a detailed history of whats been going on this week while trying to fix my computer in hopes that it will be easier to realize whats wrong:

 

HD seems infected with a Virus or HD failing or both... display properties tab missing, strange folders with mispelled names appear, VDF library on Antivirus software gets deleted when i try to scan suspect folders and after i DL library again i find a trojan or other virii which i delete. Still getting a fake "blue screen" screen saver that a previous virus installed.

 

Installed new RAM... got a long beep every 5 seconds, no bootup. switched RAM around and that fixed it. Ran comp for a week with new RAM and no problems.

 

Installed new Corsair TX650 power supply and got the beep error again. Reinstalled old power supply, got beep error. Switched RAM around again and fixed the beep error. Put the new PSU in again and it ran fine for a day or so, no problems.

 

Around this time i believe i started having problems with the HD being detected. When i booted up, the name in BIOS of the master drive would be garbled or not detected at all. I replaced the old cable with a new IDE cable and got it detected again.

 

Installed the GTX260 video card and it ran with no problems for awhile. Ran a graphic intense game with no problem, but some other games that worked with my previous config would crash. Also, when i tried to reinstall the crashing programs, or install any new program, i would get a CRC check error which i never saw before. Couldnt install anything new.

 

Now when i shut down the computer, it wont power up again unless i unplug/plugin the cable, or turn the switch off and on again.

 

At this point i started saving data from my master drive to the backup drive. It froze or rebooted a few times during this process, and the master HD name in BIOS became scrambled again or not detected. Messed around with the IDE cable till it worked again, and finished saving the data i needed.

 

Formatted the drive and reinstalled Windows XP. Attempted to reinstall drivers and download updates but during this time the comp would freeze when i was downloading or installing new updates. Eventually when rebooting the HD, name in BIOS again became scrambled and undetectable and nothing i did could solve the problem.

 

After removing all extra drives and cd players, and only leaving the one master HD hooked up, i got the beep error again. Swapping the RAM around did nothing and all devices seem plugged in correctly and seated properly.

 

I now removed the new PSU and video card, and put the old ones back in to see if i could get them working. While the power up issue isn't happening with the old PSU, i still get the beep error and can't boot the machine no matter what i try.

Link to comment
Share on other sites

  • Corsair Employees
Based on what you have said, I would not suspect that the PSU is causing any of these problems. You may also want to download and run http://www.memtest.org to see if you have any memory related issues. When you shut down the system and try to reboot it with the TX650 does anything happen at all, or is it as if you did not even press the power button?
Link to comment
Share on other sites

Actually, when the power is restored by unplugging or turning the switch off and on, the light on the scroll wheel of my mouse comes back on and stays on.

 

When i shut down the computer, that light goes off, and if i try to turn the computer on the light will light up for only a split second but the machine doesnt power on.

 

hope that helps.

Link to comment
Share on other sites

  • 2 months later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...