Jump to content
Corsair Community

XP (32 bit) only detects 2GB


virtualdanger

Recommended Posts

Hi,

 

The BIOS as well as CPUZ correctly show 4GB of RAM, but Windows only detects 2GB. I am aware that only 3GB, and in some cases a little more (for example 3.25GB) are detected and usable by windows due to the limitations of a 32 bit OS; but why is it currently only detecting 2GB?

 

Attached are the System Properties screenshot, and two Memory related CPUZ screenshoits.

 

I am currently using Windows XP SP3. And the memory is XMS2 4GB (2x2GB) TWIN2X4096-6400C5 G.

 

Thanks.

1025492864_SystemProperties.jpg.6deba42bad1848e97c0f86fa42159b97.jpg

1399608451_CPUZ-Memory.jpg.fbcb159b69f64c6eb4f1995ebb29fef8.jpg

85197077_CPUZ-SPD.jpg.212536ed71605535ecd6bc3deee29d8b.jpg

Link to comment
Share on other sites

It's an issue with the P5B (i965 chipset). I have seen this before, but only on the P5B. Almost all the P5B motherboards I have built had 2GB in, but I now remember one where I installed four GB and a dual boot between WinXP32 and Vista64. The same issue appeared when I was setting WinXP. Vista64 showed the entire amount. Had to dual boot and change remap to gain.

 

You will very likely need to move to a 64bit OS to gain your DRAM. Do not use remap for a 32bit OS and use remap for a 64 bit OS.

 

This is an issue you can bring up with ASUS as it is a chipset/mainboard issue.

Link to comment
Share on other sites

Going by this I guess there is no option or workaround. On XP 32-bit i'll need to disable the memory remap and be content with the less than 3GB or memory.

 

Asus Reply:

 

The root cause of this is due to one of the limitations of 32-bit Windows XP.

When the memory remap option has been enabled in BIOS, the occupied memory address will then be remapped to addressable spaces above 4G.

Apart from that, as memory remap function has been implemented based on 1G block unit, the available memory space between 2~4GB will then be remapped to spaces 4G.

However, as 32-bit OS does not recognize anything above 4G, consequently, the remapped 2GB will be lost, hence reduces the available memory space down to 2GB.

Due to this reason, it is highly recommended to disable memory remapping option when using 32bit OS.

Link to comment
Share on other sites

Going by this I guess there is no option or workaround. On XP 32-bit i'll need to disable the memory remap and be content with the less than 3GB or memory.

 

Well, I think that the i965 chipset is at fault though. A P35 and higher chipset will allow for the usual 2.75+ GB with a 4GB remap to a 64bit OS. No need to enter BIOS and make changes.

 

At any rate, you're still better off with 2.5GB than 2.0GB. Just remember to set the remap when you transition to a 64bit OS.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...