Jump to content
Corsair Community

620HX is cycling power, reboot loop


Halonut

Recommended Posts

Hello!

 

I have an intermittant issue with my newly built system. When I press the power button, the system will sometimes attempt to power up, immediately recycle and enter a boot up reloop. This will continue until I depress the power button for 5 seconds to shut down. Another attempt to power up will often result in the system starting as it should. The system will then remain stable for as long as I'm using it.

 

I cannot establish a pattern for this failure and am wondering if the PSU may be defective?

 

Thanks!

Link to comment
Share on other sites

  • Corsair Employees

I would suspect that this is a BIOS issue. I would recommend that you make sure you have the latest BIOS for your system, load setup defaults, and then reconfigure any manual settings.

 

If you would like to see if the PSU is responsible, then I would try this test and see if the PSU is restarting itself for some reason or if the issue is with the board/BIOS.

Link to comment
Share on other sites

I'm running into the same problem, but on a constant basis.

 

My sustem boots for 30 seconds, restarts then runs for 45 seconds more before restarting a second time and remaining on. Throughout the process, the screen stays black. I've swapped the memory: works fne. Swapped the VGA: works fine.

 

Any ideas?

 

My current system is a HX620 powered Asus Maximus II Formula with a Q9550.

Link to comment
Share on other sites

  • Corsair Employees
I'm running into the same problem, but on a constant basis.

 

My sustem boots for 30 seconds, restarts then runs for 45 seconds more before restarting a second time and remaining on. Throughout the process, the screen stays black. I've swapped the memory: works fne. Swapped the VGA: works fine.

 

Any ideas?

 

My current system is a HX620 powered Asus Maximus II Formula with a Q9550.

 

I would suggest that you try the same thing. Update your BIOS to the latest version, load setup defaults and if you still have problems, try the basic functionality test linked above, and see if the PSU is shutting down on its own. I would suspect its a BIOS related issue, but you may want to contact the motherboard maker to get their opinion.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...