Jump to content
Corsair Community

Roughly 6 month old 4GB Survior. Didn't.


Recommended Posts

Around six months ago, i got my hands on one of your rather nice 4GB Flash Survivor drives. All was well, until a few hours ago when i plugged it in. It mounted as per normal, and the windows autorun dialog popped up, i went to open a file on the drive, spent a moment going through the directories to get to the file i wanted, and, as soon as i tried to open it, it through an error saying it was unable to find the file specified. Attempts to move, copy or delete files on the drive result in a "Cannot Read From source File or Disk" error, and formatting fails (IOCTL call failed, apparently). I have tried alternative formatting methods, with no success. The drive would, for a time, mount perfectly when plugged in, and could be used normally for slightly less than a minute before whatever attempts to access files on it throw errors. Now it simply mounts, you get the root file and folder list, but that's as far as it goes, it is impossible to do anything other than view the list.

So, what shall i do? Anyone got any useful suggestions about how to repair my rather destroyed flash drive?

Thanks in advance.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...