Jump to content
Corsair Community

32GB Survivor -


Recommended Posts

I think my 32GB Survivor.....died


I've had the unit about a week and had the flash filled to about 25% capacity. I made one last successful wite to the unit before removing it from my laptop. I put the flash into a desktop and started reading files (at the time a pdf) when i started getting various errors about the disk not being in the drive. I "safely removed" the hardware and put tried it in my laptop again.


I get the same result now no matter what machine i try it in.

The flash unit will be given a drive letter, but attempst to read or write to it return the "Please insert a disk into Drive:"

The flash had a name that would show up before The Great Crash, now it won't. I'm pretty sure the coffin is nailed shut because the light on the unit doesn't even flicker when i insert the flash into a USB port.


Any suggestions?

Link to comment
Share on other sites

  • Corsair Employees

Please try to format the drive from a command prompt with this syntax:

Format (X:) /FS:FAT32 /U (X=the drive letter assigned to the Flash Voyager)

If you still have problems we can get it or them replaced, please use the RMA request found in TSXpress or follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...