Jump to content
Corsair Community

Striker extreme xms2 6400 800mhz 2x1gb does not compute


Recommended Posts



My corsair xms2 6400 800mhz 2x1gb doesnt work with my motherboard asus striker extreme. Ive been able to use one of the sticks for about a year but using both sticks will result in failiure to boot or before i updated to latest bios (1603) the det dram error.


Ive tried setting voltage to 1.9, 2.0, 2.1 and still no results.


I've tried using two valueselect sticks at 512 mb each instead, and the system boots fine, so doesnt that mean I can rule out the possibility of the board being defect?


Even though I know you label these two components as compatible Im now thinking of changing to some other ram brand to see if this is in fact due to a compatibility issue, but i would like to hear any suggestions to what else i could do to fix this.



Link to comment
Share on other sites

Ive tried them in all possible combinations. Up until now i had

a fairly stabile system on slots x1-x1 (or 2 and 4 as you put it),

but this morning the error occured again.


I reinstallled windows yesterday, but that shouldnt change any



It's almost as if every other time I cold boot the computer the

error kicks in, how can you call something stabile that doesnt

work at any regular temperature, ridiculous.


I bet if I let the computer stand running for a while with one

stick, reinsert the other and reboot it'll all work nicely...


I think im gonna scrap this piece of **** motherboard and go with

something less asus and less fancy that actually works reliably,

the striker extreme and all its decendants are nothing but spoiled,

overrated, overpriced brats.


More money down the drain...

Link to comment
Share on other sites

10 minutes or so after last message I rebooted with both

sticks and the system starts up fine saying 2gb ram in

windows system spec.


I guess ill have to leave the computer standing idle when i

dont use it, vaccuming the appartment for me.

Link to comment
Share on other sites

  • Corsair Employees
Please make sure that you have the latest bios and load setup defaults and then set the memory Voltage to 2.1 Volts then set the timings manually to the tested settings for the specific module you have, and test the modules one at a time with http://www.memtest.org to be sure one is not failing. If you still get errors, please follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it! However, if you get errors with both modules that would suggest some other problem and I would test them in another system or MB to be sure. In addition, with some MB's (Mostly ASUS) you have to disable legacy USB in the bios when running any memory test.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...