Jump to content
Corsair Community

Bad RAM, requesting RMA#


acropolen

Recommended Posts

Hello, my computer has been giving me the blue screen lately and after running a diagnostic utility, it has found errors on both my ram sticks. The model is TWIN2X4096-8500C5 and I bought it from newegg. The warranty page on the corsair website says I need the label containing the corsair part number. I have (much to my recent disdain) thrown away the packaging that the ram arrived in. Is the label in question on the ram itself or the packaging which should be at the local dump right about now? If the label is on the ram, where is it and what will it look like. Also can I get an RMA# to get this replaced if I give you the part number? I appreciate any assistance.
Link to comment
Share on other sites

  • Corsair Employees

Please make sure that you have the latest Bios version and then load setup/optimized defaults and set the Dim Voltage to 2.1 volts (+.3 Volts W/Giga-Byte) and then set the timings manually to the tested settings for the specific module you have, and then test the module/'s one at a time with http://www.memtest.org! If you still get errors, please follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it! However, if you get errors with both modules that would suggest some other problem and I would test them in another system or MB to be sure. In addition, with some MB's (Mostly ASUS) you have to disable legacy USB in the bios when running any memory test.

 

But yes dont worry we can replace them if needed.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...