Jump to content
Corsair Community

Voyager 16GB no longer recognized on PS3


Recommended Posts

I bought a 16GB Voyager for use with my Playstation 3. I used it for a couple of weeks going back and forth between my WinXP PC and my PS3 with no issues, but then it stopped being recognized by my PS3. I tried to use it with my TV, and it isn't recognized by that either, but I didn't try that until after it stopped working with the PS3, so I don't know if it ever woul dhave worked with it or not. When I plug it into my WinXP PC, it now takes a LONG time to show up, but it does finally get recognized. Has anyone experienced this issue? Any suggestions?


Oh...and the LED doesn't light up except for a quick flash on the PC and not at all with other devices.



Link to comment
Share on other sites

  • Corsair Employees

Please try to format the drive from a command prompt with this syntax:

Format (X:) /FS:FAT32 /U (X=the drive letter assigned to the Flash Voyager)

If you still have problems we can get it or them replaced, please use the RMA request found in TSXpress or follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...