Jump to content
Corsair Community

Problems with the display


Mr.Monkey

Recommended Posts

The HC unit still works, but i've been having problems recently. The lcd display has been on the blink, with the unit beeping to indicate it has lost the signal from the thermostat (the fan also goes to turbo). The the lcd unit resets, and tells the temperature normally. This happens every few hours or so, but now the display has gone altogether. It doesn't even light up. Does anyone know where there are othen loose connections or anything that might cause this problem? The re-seller I bough the unit from in the UK has since closed down, so I can't take it back to them.
Link to comment
Share on other sites

  • Corsair Employees
Are you using the power extender cable that came with the HC unit to plug power into the card? Does the rest of the unit still power on and work? The front panel display resetting is a power issue. If all the connections are secure I would suggest trying a plug from your power supply that is on another cable. Let me know. Thanks!
Link to comment
Share on other sites

[quote name='COOL GUY']Are you using the power extender cable that came with the HC unit to plug power into the card? Does the rest of the unit still power on and work? The front panel display resetting is a power issue. If all the connections are secure I would suggest trying a plug from your power supply that is on another cable. Let me know. Thanks![/QUOTE] Good catch! I'd added a new fan to that gang of plugs. Putting it onto a different line sorted the problem out. Many thanks!
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...