Jump to content
Corsair Community

16gb voyager not working


Recommended Posts

I just bought a Corsair Voyager 16gb Drive (CMFUSB2.0-16GB A) and it just would not work anymore.


It worked fine when I first plugged it in. I formatted it using HP USB Disk Format Storage Tool in NTFS. Then I copied the documents I needed but when I restarted the pc instead of a disk Labelled CORSAIR I found a Removable Drive.


Now I cannot open the drive and I cannot format it either. I tried using it on other pc's and operating systems but nothing seemed to work.



Any ideas?

Link to comment
Share on other sites

  • 2 months later...

I'm having similar problems. I bought and received the CMFUSB2.0-16GB from NewEgg. I plugged it into my laptop (VISTA) and it showed. I got a call and had to go out so I removed it from my laptop. I plugged it into my home pc (XP) when I returned and it won't do anything. No light and although it does "load" and show in Windows Explorer when I click on the drive letter I get an error message asking to insert a disk. I've tried formatting it, including from the command prompt and that won't either.







Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...