Jump to content
Corsair Community

Solution for problems with usb-stick with prolific controller


Recommended Posts

Hello, I have a fix for this problem after having posted it for a differently branded stick, but with the same prolific controller on bugzilla.


See bugzilla #11640


Whenever you create multiple partitions or a non fat(32) file system in a partition on the stick the inquiry of the stick timeouts. The default linux timeout is set for 5 secs, and the stick takes 14.5 seconds. So if you set the timeout to 15 seconds or more, and reinsert the stick, the stick should be mountable and readable. Just remember to add this to your boot scripts, or repeat it every time you reboot the kernel.


The inquiry timeout can be set to 15 sec with the following command line:

echo 15 >/sys/module/scsi_mod/parameters/inq_timeout

Or if you prefer the grub command line is :


I hope this longer timeout will someday be standard for the kernel. Or maybe part of an exception list when a prolific 2528 stick is detected.



Link to comment
Share on other sites

------- Comment #10 From Monchi 2008-09-25 22:36:35 [reply] -------


Could this longer inq timeout become part of a greylisted usb-stick chipset ?

Because many people on the corsair forum have the same problem. Different sick

manufacturer same usb->flash controller.



------- Comment #11 From Alan Stern 2008-09-26 07:12:26 [reply] -------


I don't know -- the inq_timeout setting is global, affect every SCSI device

added to the system, not just an individual USB device. However testing shows

that Windows XP uses a timeout of 20 seconds for USB storage devices.


I'll ask on the SCSI development mailing list.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...