Jump to content
Corsair Community

Strike 2 with TWIN2X2048-6400C4D


Recommended Posts

I originally purchased the TWIN2X2048-6400C4D memory set from NewEgg.com for a gaming PC I was going to build. The new computer worked fine for web surfing, music, and word processing, but would have problems playing games. Some games would have the screen freeze with the audio still running before crashing the game and showing a box saying the display driver had failed. Other games would have odd textures appear in surfaces before displaying the same error message. This happened with new games (GRID) and old (Doom 3, Painkiller). Sometimes the games would run for just a few minutes, other times it would go for an hour before crashing.


I first thought it might have to do with one, or both, of the ******** 8800GT 512MB graphics cards I was running in SLI. I updated drivers for the cards and for the motherboard (Asus P5N-E SLI), but still had the same problem. I tried both cards separately...no luck. After Googling my problem, I decided to test the memory.


I ran both Memtest 86 and Memtest 86+ on each of the individual sticks. One of them was fine. The other had some problems. It came back with a repeating error in Test 5 in Memtest 86 within a few minutes which required a manual restart of the computer. Memtest 86+ returned multiple Test 5 errors within 13 minutes. I went to the Tech Support Express page and entered my info. An RMA was approved on August 22 (Case #657158). I shipped both sticks back and waited for the replacements.


On Tuesday (September 9), the replacements arrived. Before plugging both of the modules in and booting up as normal, I decided to run Memtest on both of them individually first. The first stick was fine. It ran for eight passes with no errors reported. I booted into Windows and everything appears to run fine (haven't tried the games yet).


The second stick has serious problems. The computer won't POST. Nothing appears on the screen after the computer is turned on. I tried pairing it with the good stick to see if I could get into Windows or the BIOS to see if the second module would even be recognized, but no luck there either. It did the same thing -- no POST, blank black screen. I tried it in all 4 RAM slots on the motherboard -- same thing (other stick worked fine in each slot).


I compared the physical appearances of each of the modules looking for any possible damage and found something different on the defective one. It appears to be a stray drop of solder possibly touching the contacts on the bottom of the module. I took a couple of quick pictures for reference (see attached).



So, as the title of the post says, this is Strike 2 for me with this set of memory. Each time I've received one stick that's fine and one that isn't. I can understand an occasional bad apple in the bunch, but I've received two in a row. Corsair is a company I trust because I know they stand behind their product, but if these are going to be RMA'd back, I'm stuck paying postage a second time to return a faulty item. Any help you can provide, RAM GUY, would be much appreciated. Thanks.



Link to comment
Share on other sites

  • Corsair Employees
With the good stick installed, please set the memory voltage to 2.1 volts, and then retest the questionable module. If there is no change, then we will want to replace this kit for you. If this is the case, then please contact our customer service at 888-222-4346 and dial "0", (510) 657-8747 or email rmaservice@corsairmemory.com, let them know a replacement set has failed, and provide them with your old RMA number. They should be able to help you out with shipping, and expedite this case ASAP.
Link to comment
Share on other sites

My BIOS settings did not list 2.1V as a choice for the memory voltage. There are settings for 2.085V and 2.178V. I selected 2.178V and retested the second module. I got the same result as before -- no POST, blank black screen. I will be calling customer service as you suggested. Thanks for the help.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...