Jump to content
Corsair Community

Dominator 8500C5D Concerns


Recommended Posts

I've had a pair of 1gb Dominator 8500C5D sticks for a while now and I run these just fine at 1062 mhz with my system (2.1 volts).


Yesterday I bought a second pair to get to 4gb. Before I put them all in together I decided to put in just the new pair to see if they were working as they should.


Problems right away, got massive errors in memtest86+ 2.01. Allright I thought, went back to the store and got them replaced.


With the second pair of modules the computer wouldn't even start. The new modules were version 4.1 and my old sticks are version 2.1.


At any time I can put in just my old 2.1 sticks and run a full Memtest, no errors. Power down the system, pull my 2.1 stick out, and put in just the new sticks, and I get massive errors or no boot at all.


Is it possible that I can be so unlucky that I got two broken pairs?


If I run the new modules on 800mhz though they work just fine in Memtest. But since the box clealy states 1066mhz they should at least work on that speed when just 1 pair is installed? I've tried uping the voltage to 2.2, and also the NB and DDR-REF voltages, no difference.


Got an Asus Commando board with a E6420 CPU.

Link to comment
Share on other sites

  • Corsair Employees
Make sure you have the latest BIOS for the motherboard, load setup/optimized defaults in the BIOS, and set the memory frequency to 1066Mhz and the memory voltage to 2.1 volts. Test the modules one at a time in the slot closest to the CPU, and let us know your results!
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...