Jump to content
Corsair Community

Random BSODs with P5E3 & Q9300 & TWIN3X2048-1333C9DHX


Recommended Posts

Hi everyone!


Around a month ago I build myself a new computer.

The old one was giving me headaches with BSODs and, as it was over 4 years old, I decided to go for a brand new system instead of tracing where the root of the cause lies. Unfortunately, the things didn't turn out as well as I had hoped for :(


At first, I was only running on the Win Vista 64... but soon after I got several BSODs I thought it would be a good thing to check the system on 32-bit Win XP OS. Just a couple of minutes after the (successfull) installation of the Win XP ... and a BSOD again. All other tests from this point were made on the Win XP to rule out any Vista or 64-bit incompatibilities.



After that, I went for HW testing. The first to come was the RAM :)

Having the sticks in dual channel mode resulted in several thousands of errors in memtest.

Testing the sticks one after another resulted in no errors at all.

Then I found many posts here advising to increase the DRAM voltage to 1.7V and test while having the USB legacy disabled.

So I did and guess what - no errors with both sticks in dual channel mode after 8 passes in memtest.


Started windows again but the BSODs were still appearing, although, not as often as before.


And so I went for prime95 testing.

Couldn't count even a minute before the first error showed up (in blend mode).

Later, I ran the small FFT test, which was running much smoother. I did not get any error while running this test, but I did not run it for longer than 30 minutes.

After that, I pulled one stick out of the MB and ran the blend mode torture test for over 12 hours without any error!


Seems like I'm having some sort of a dual-channel problems.

However, this is far beyond my field of expertise and I really could use some help to get this resolved.


What I'm aiming for is not an overclocked system. What I need is a stable system that can be used for years to come.

Thanks a lot for any help in advance!




the BIOS settings are all at stock, only DRAM voltage is set to 1.7V

Link to comment
Share on other sites

  • Corsair Employees
Please make sure that you have the latest bios and load setup defaults and then set the memory Voltage to 1.7-1.8 Volts then set the timings manually to the tested settings for the specific module you have, and test the modules one at a time with http://www.memtest.org to be sure one is not failing. If you still get errors, please follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it! However, if you get errors with both modules that would suggest some other problem and I would test them in another system or MB to be sure. In addition, with some MB's (Mostly ASUS) you have to disable legacy USB in the bios when running any memory test.
Link to comment
Share on other sites

I don't think I have a bad RAM sticks. I tested them separately already and they did not show any errors.

After setting the voltage to 1.7V and disabling the USB legacy, I didn't get any errors even in dual channel mode after 8 passes of memtest.


However, running prime95 still suggests that there is a problem with dual channel. When running the blend torture test with both sticks in dual channel, I get errors within a minute. When I ran the same test with only one stick at a time, I could run the test for over 12 hrs.


I suppose this could mean that the MB is defective. I'm still hoping though that the problems could be solved by different settings in BIOS.


I'll guess I'll give it a try with 1.8V and setting the timings manually.

Link to comment
Share on other sites

Alright.. another round of testing, here are the results:


  • 1.7V with timings manually set at 9-9-9-24, sticks in dual channel mode -> to my surprise, I got errors at test #8 in memtest.
    I have a screenshot of 7 successfull passes with the same settings from previous testings ..apparently, 7 was not enough!
  • 1.8V with timings manually set at 9-9-9-24, sticks in dual channel mode -> no errors after 3 passes (didn't have more time to test)
    • with those settings I started Prime95 torture test, blend mode -> Error after around 2 minutes
    • swapped the sticks to the other channel slots -> ran Prime95 and got error after around 3 minutes


Then I pulled out one of the sticks (that's when the system is stable and can run Prime95 for hours) and noticed an interesting thing when browsing through CPU-Z.

  • When I have both sticks on, the command rate gets set to 1T
  • When I only have one stick on, the command rate gets set to 2T

Makes me wonder.. what is the difference between them and could it help to set the command rate manually to 2T with both sticks on?

Link to comment
Share on other sites

Thank you for the suggestions, but I'm not entirely sure what you mean by 'resetting' BIOS. Do you want me to revert back to the version with which the MB was delivered to me?


Other than that, I did the following:

  • load defaults in BIOS (version 1104)
  • disabled the USB legacy
  • set the DRAM voltage to 1.7V
  • set the timings manually as follows:
    • CAS# latency: 9
    • RAS# to CAS# delay: 9
    • RAS# to PRE time: 9
    • RAS# ACT time: 24
    • RAS# to RAS# time: Auto
    • REF Cycle time: 72
    • WRITE recovery time: 10
    • READ to PRE time: Auto


There was no problem with post, so I ran memtest for errors.

It ran two passes without finding any error (unfortunately, I didn't have time for more passes today).. so I tested with prime afterwards and got errors there.


I also tried raising the voltage to 1.8V and setting the command rate to 2T, but the prime blend test resulted in errors as well.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...