Jump to content
Corsair Community

New Build Gets Power, Won't Power On


Recommended Posts

This will be a bit of a lengthy explanation, so please bear with me.


I recently purchased parts for and assembled a new computer. The hardware is in my profile, if there is other information that could be helpful, please let me know. Anyway, I got all the parts, put it together, powered it on, and ran Memtest for 24 hours. No issues.


The next day I was applying patches to Vista and walked away to let the machine reboot. I came back and it was powered down, I couldn't get it to power on. The motherboard has status LEDs, none of which were showing errors, onboard reset, power, and Cmos reset buttons, which all light up. At the time, all these lights were lit, but when I pressed either of the power buttons, nothing at all happened. It reacted the same way an unplugged computer would if you hit the power button.


I plugged my old computer back in and looked for some assistance. I then unplugged all the power connections and tested the power supply with a paperclip per the Corsair FAQ. The power supply tested good, like I figured, and I plugged everything back in. It powered up then, and I figured that maybe I hadn't had a connection seated properly.


The computer ran without issue for two weeks. I was able to leave it on 24/7, and played Crysis without incident. I figure if it was an underpower issue, it would have tanked somewhere around then.


Then the issue happened again. I repeated the testing process and still couldn't get it to come on. Long story short, I ended up RMAing the motherboard to NewEgg. I just received the replacement last night, plugged it in, and it was giving me the same issue.


I'm not sure that the issue is with the power supply, but there really isn't a whole lot of other hardware involved with getting the thing to just power up.


If you have any ideas or recommendations for what might be going on, please let me know. At this point, I'll try just about anything.


Edit: I hadn't touched any overclocking options in the BIOS. All I had changed was the boot order, and not even that much with the replacement board.


Edit 2: I've tried removing the motherboard from the case and booting with just RAM. Same issue, so I doubt anything is shorting out on the case.


Edit 3: I haven't tested with a different power supply. The one in my current computer would be too small, and I don't have any other machines to pull a PSU out of. I asked a friend to let me borrow an extra one he has, but I won't see him again for another four days or so.

Link to comment
Share on other sites

  • Corsair Employees
I would test your video cards one at a time to see if there is any change, or if possible, test the TX750 in your other system to see if you have the same problems. Does the fan on the PSU even spin up at all when you try to power on the system? Have you tried bypassing the power button on the case by bridging the PWR pins on the board (you can use the tip of a screwdriver to do this).
Link to comment
Share on other sites

Well, the computer doesn't boot even when both video cards are removed. I had the mobo out of the case with only the RAM, 4-pin and 24-pin connectors, and the heatsink fan installed.


When I try to power on the system, nothing at all happens. None of the fans, including the PSU, spin up, it's as though I'm hitting the power button of an unplugged machine.


I haven't tried bridging the connectors. I've been using the on-motherboard power button exclusively while trying to get it to work.


I'll have to try the current PSU in the old system as soon as I am able, but it'll be a few days.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...