Jump to content
Corsair Community

Twin2x2048-6400C4DHX faulty DIMM


adrians

Recommended Posts

Hello,

 

In possession of a Twin2x4096-6400C4DHX kit, which lately has started giving some trouble.

 

The annoying part:

- some games freeze for a few seconds

- some textures/buttons usually disappear after these hiccups

- installation of WinXP Home gives blue screens (no specific info returned) before the first reboot

- general instability when system is under load (running applications, not necessarly benchmarks)

 

The initial system where the bad behavior was spotted:

- Gigabyte EP45-DS3 (latest BIOS)

- E8200

- GeForce 8800 GTS 512 (by the way, this just got back from RMA)

- the memories I was talking about

- Seasonic 550W S12+ powered system

 

OK, going preety bad, I said let's switch on the older computer:

- Gigabyte EP35-DS4 (latest BIOS also)

- E4300

- Geforce 8800GS (not new, about 2 moths old, perfectly working)

- switched the 2x1G Corsair 667 XMS2 with the subject memories

- Fortron 400W BlueStormII power source

 

Some notes:

- I do NOT overclock my systems (never did, never will...I guess)

- I tried the memories with all params on Auto/SPD, then one step at a time I changed the voltage to 2.08V (2.1V certified), then manually changed timings to 4-4-12 (as specified on the DIMMs); no improvement.

 

Next step: let's see if the DIMMs are working separately (used 1st system). There was a visible improvement - really, no complains here, even with 2G of RAM, everything was flying. Switched to 2nd DIMM: well, bad as before. So I guess something was bad with this DIMM.

 

Testing starts: Memtest for windows at 700+% coverage shows no error. Mkay..., let's switch to another tool: Windows Memory Diagnostic. Result: tests MATS+ and Strider6 (both with cache OFF) were failing: about 2400 faulty addresses, grouped in 2 "holes", error information: expected: ffff_ffff, received: ffff_7fff (I don't remember the exact address ranges). So I guess 1 bit line is locked to 0.

 

Since I've tested with WinMemDiag for the 1st time, I wanted to see if the 2nd DIMM (the good one) was indeed fine. And it was: "No errors detected...".

 

Wanted to try also with MemTest86+, but P45 chipset is not yet supported, the app. locks computer when loading.

 

Next morning I went to the local reseller, handed over the kit, and the 2nd day I was called that I can go and take them back, they're "...fine, Memtest for DOS ran with your DIMMs for 2 hours and returned no error". I was preety disappointed, I explained exactly what tool I used and the cache OFF stuff, and they said they're going to send them "to an authorized service" for further testing. Now probably they will run Memtest again, see no error and return them back to me.

 

I tried to see what Memtest86+ does on the 2nd system, and I've seen that every test runs with cache:on, no way to disable it. Also, took some time to check on memtest forums about this, looks like I was not the only one seeing memtest pass while other diagnostic software were returning errors when cache was turned off.

 

Now my question to you: is Memtest the only tool that Corsair considers "legitimate" to detect memory errors? Could my test/tool, as described above, be considered a proof that one DIMM is faulty?

 

Thanks in advance.

 

PS: sorry for the long post, I thought you'd better have the whole picture

Link to comment
Share on other sites

Hi,

 

Thank you for the fast answer, but I was actually hoping for an answer to my question.

 

Because I live on the other side of the world, sending the kit to RMA would cost me 80 - 90% of the kit price (just checked today with 3 companies) - therefore I don't think this will happen.

 

An answer from your side would have been a good backup for me to try to solve the problem locally.

 

Thank you.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...