Jump to content
Corsair Community

Problems with several of my drives


DerMann

Recommended Posts

I bought two 4GB Flash Voyagers for use at school last year, and about half-way through the year, one of them fell in a puddle of water. It still worked, but it was only recognised as 2GB. The other drive started suffering from odd errors in which I could not copy files to it (either large or small) as it would tell me that the drive was in use or restricted.

 

I kept the 2GB one because I needed it for school. I sent the other one back and a replacement was sent to me. It worked fine for quite some time. In June it began giving me the same errors.

 

As a result, I purchased a 16GB Flash Survivor from NewEgg on sale. I got it last Monday and used it lightly very lightly. On Friday night I attended a LAN party and used it to transfer patches between friends computers. One of my friend's used it and said it wouldn't pop-up on his computer (Vista). I just assumed that it was an issue with Vista. Then later in the night I couldn't get my computer to recognise it. When I got home, I plugged it into my laptop and noticed that not only did the computer not recognise it, but the LED on the drive did not light up.

 

 

-Josh K.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...