Jump to content
Corsair Community

I Can´t Access Flash Voyager 512 Mb


Gixman

Recommended Posts

I´m sure that the most of you are going to suggest to buy a new Flash Memory and I know that they are pretty cheap. But it happen to be that I like it very much and it is the Space I need.

 

Anyway a had a 400 MB partition and a 112 mb of a password protected partition. It was created with the CORSAIR FLASH VOYAYER UTILITY. It has been working ok since I own it, It has been almost for 3 years. Well since a few days ago. I tried to use it and it was impossible for any computer to recognize the Flash Memory. I´ve tried to recover the information, Format any partition, but I´ve got several Messages, sometimes I get strange characters, sometimes the computer doesn´t rocognize it at all, sometimes the corsair utilities doesn´t work or it appears with the description PROLIFIC USB-Flash-Disk USB Device. And I haven´t ever use such device with that description.

 

If you have Any Suggestion Please let me know I would like to recover this Memory.

 

Thanks

 

Gustavo

Link to comment
Share on other sites

  • Corsair Employees

Please try and format your Flash Voyager with Corsair EZ-Recover Utility. Please note; this will not recover Data; it’s made to recover the FAT table for the Flash drive.

But First if you need to recover some data there are some third party utilities available that may help you if you have some data you need to recover from this site.

If you still have problems, let’s get it replaced. Please use the RMA request found in TSXpress or follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...