Jump to content
Corsair Community

Asus P5K and TWIN2X2048-8500C5D (Dominator) not compatible @1066?


Recommended Posts

setup: asus P5K, intel E6850, corsair TWIN2X2048-8500C5D, asus 8800gts640, corsair 750W psu


modules are running flawlessly at SPD (DDR2-800, pc-6400 specs)

but no POST at 1066 (using 5-5-5-15-2T 2.2V, latest p5K bios, no overclocking)


tried many, many, many tips/tricks etc found online.... :bigeyes:

so please RAM guy :), is it possible to run these modules on a p5K or not?

(I found contradictory statements about this online...:confused:)



Link to comment
Share on other sites

I have run 8500C5 on almost every iteration of P5K boards. There is no issue. So let's see what's wrong.

Download memtest from--->
and extract the ISO image. Burn the ISO image to an CD-ROM disk.

Enter your BIOS. Load setup defaults, save setup defaults and set to these values:

AI Overclocking: Manual

CPU Ratio Control: 9

FSB Frequency: 333

PCI-E Frequency: 100

DRAM Command Rate: 2T

DRAM Frequency: 1066

FSB Strap to Northbridge: 333

DRAM Timing Control: Manual


CAS# Latency: 5

RAS# to CAS# Delay: 5

RAS# Precharge: 5

RAS# Activate to Precharge: 15

TWR: Auto

TRFC: Auto

TWTR: Auto

TRRD: Auto

TRTP: Auto


DRAM Static Read Control: Disabled

Transaction Booster: Auto

Clock Over-Charging Mode: Auto


CPU Spread Spectrum: Enabled

PCIE Spread Spectrum:Enabled

CPU Voltage: Auto

CPU Voltage Reference: Auto

CPU Voltage Damper: Enabled

CPU PLL Voltage: Auto

DRAM Voltage: 2.2v (for version 1.xx) or 2.1v (for version 2.xx+)

FSB Termination Voltage: Auto

North Bridge Voltage: 1.4

North Bridge Voltage Reference: Auto

South Bridge Voltage: Auto


Transaction Booster: Auto

Advance CPU Settings

CPU Ratio Control: Auto

C1E Suppport: Enabled

Max CPUID Value Limit: Disabled

Vanderpool Technology: Enabled

CPU TM Function: Disabled

Execute Disable Bit: Disabled

PECI: Disabled


Shut the system down. Boot to the Memtest CD. Allow for two full passes unless errors occur. If errors occur.



Remove one stick of DRAM. Leave the first stick (Closest to the CPU) in and boot to the Memtest CD. Allow for two full passes. Remove and replace with the second stick. Retest. If the sticks pass, then test with a single stick in the second slot, then third slot, and finally fourth slot.

Link to comment
Share on other sites

(lost all i was typing so i'll try again :o:)


hi and thanks for the extensive help!


first I fixed the "no post" problem using this workaround:


(removed both corsair memory modules, insert samsung pc5300 single module closest to cpu, post ok, enter bios, change DIMM speed from AUTO to DDR800 (or DDR667), removed samsung module, insert single corsair pc8500 module, post ok, insert second corsair pc8500 module, post ok, boot with memtest86+ 2.01, ran 2 passes: 0 faults so memory is ok at DDR800 (SPD setting)


then I entered all settings from DerekT, except the ones below:

*** CPU Spread Spectrum: Enabled -> left on AUTO, no ENABLE in list, only AUTO AND DISABLE...??

*** PCIE Spread Spectrum:Enabled -> left on AUTO, no ENABLE in list, only AUTO/DISABLE...??

*** PECI: Disabled -> parameter not found under advanced cpu setting...???


after reboot: no POST :roll::roll::roll:

so I can't get in the bios to change things, I have to start at at the beginning again to solve the "no post" problem :(:


any suggestions/additions to your bios settings that might work?

I wanted to test the memory at 1066 but without a POST that will be difficult :p:

Link to comment
Share on other sites

  • Corsair Employees
I would try and clear the BIOS and see if it will post with just one module installed and if so you should get the latest BIOS installed and then load setup defaults and set the memory Voltage to 2.1 Volts.
Link to comment
Share on other sites

I lied... :eek: :laughing:


I did not have the last bios version (thought I had...) Asus released a new bios a few weeks ago: version 1005. According to them to "Enhance compatibility with certain memory module.":roll:


Also, corsair memory is version 2.3, and runs according to the label at 2.15V (not 2.1V or 2.2V - but 2.2V which I tried should still be ok hmmm...)


@ram guy: i'll now try to run a single module @1066 after I have flashed the bios to v1005, and then run a memtest, insert second, etc...

Link to comment
Share on other sites

it works! :biggrin::biggrin: After weeks of experimenting, giving up and starting again several times it finally works. Thanks to settings provided by DerekT and the Asus P5K 1005 bios posted March2008. Thanks RAM guy and DerekT for prompt response. great, guys! The memory runs rock solid at 1066, I ran 2 passes of memtest86+, no problems whatsoever.



Now that I know that the memory is stable, I could start to play... My E6850 runs fine at 3.6 with 400fsb, 1:1 ratio and thus memory at spd spec again :laughing: My original goal was because of the 5:6 ratio to run fsb at 444, thus memory at 533 (1066). That's why I bought the Dominator in the first place ;): Now I can finally search for the limit, both in fsb (with stock cpu cooler...), and the corsair memory (without memory fans).


Link to comment
Share on other sites

  • Corsair Employees
I doubt that will work out that way, from what I have seen when the CPU FSB gets much over 333 MHz the memory frequency will have to be more insync with the CPU but with the newer chipsets they might be able to run the divider settings a bit better so just try it and see.
Link to comment
Share on other sites

  • 3 weeks later...

P5K TWIN2X2048-8500C5D (2.2V ver4.1) E8200


Hi guys, please excuse my english, I'm french ;):


I bought this MB one week ago, with the E8200 and Corsair memory.


I had no post, so after reading forums, I bought a Kingston 512Mb PC5300, and the POST is always ok with this memory.


Please notice I've NEVER had POST ok with Corsair memory


I've tested many differents BIOS setups, with 0902 and 1005 versions, put single memory and dual in both yellow and black slots, cleared CMOS each time I've flashed the BIOS....


I'm not a beginner, but this time I need help, because I bought 2Gb@1066Mhz and the only way for me to hear a beep is to put 512Mb@667Mhz :(:


Can someone tell me which BIOS to use and every settings I have to put, because when I read this topic, I see people who have successfully installed this Corsair Memory...


Thank you guys, have a nice day !



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...