Jump to content
Corsair Community

Seeing wrong size and speed of memory


Zadkiel

Recommended Posts

OK, so I decided to give myself a bit of a system boost and bought 2x Corsair XMS2-5400 2x1GB (total of 4GB on 4 sticks) to replace my existing 2GB of ram which was running at 667/5-5-5-15 - the corsair stuff was advertised at 675/4-4-4-12. Faster and more memory, yay! I'm running a 32-bit OS and have 512MB of vram, so I wasn't expecting to see the full 4GB at the OS, but I should see a significant increase, right?

 

wrong.

 

Firstly, Windows is only seeing 2.5GB !! During post I see the 4GB, but Windows is only seeing 2.5 :( I was expecting at least 3, if not 3.5.

 

Secondly, it's running at 5-5-5-15 ! So I spent all that money and went from 2GB at 5-5-5-15 to 2.5GB at 5-5-5-15. Ummm...

 

If I inspect the SPD using something like CPU-Z it reports that at 333MHz (667FSB) it rated at 5-5-5-15 and at 266MHz(533FSB) it's rated at 4-4-4-12.

 

But the memory I bought quite clearly says 4-4-4-12 at 667/675FSB. It says it on the box, it says it on the sticker on the ram sticks, it says it on the site I bought it from, but the SPD disagrees.

 

Help?

Link to comment
Share on other sites

  • Corsair Employees
With 4 modules I would set the memory Voltage to 2.0 Volts and set the NB/MCH/SPP Voltage to 1.45 Volts and then test the system with http://www.memtest.org and if it's showing the memory size correctly in BIOS it is probably the O.S. and any 32-Bit O.S. will not see the full size of memory. About 2.6-3.4 Gig will be available.
Link to comment
Share on other sites

Well, having researched this further, the problem appears to be that the SPD is set to 5-5-5-15 although the product is advertised as being 4-4-4-12. We are expected to manually adjust the timings if we want to run at faster than the SPD.

 

The problem is that this requirement was not mentioned when I bought it, and my MB does not allow for any overclocking of the memory except for the FSB speed, I cannot override SPD.

 

From within Windows I can use ntune (Nvidia app) to change the memory timings, but although it lets you change most things, it doesn't let you change CAS - So I'm now running at 675 (tweaked in BIOS from 667) and 5-4-4-12. Unfortunately, of all the timings, CAS is the most important one - 5-4-4-12 is only a marginal improvement over 5-5-5-15, dropping to CAS4 would see a significant performance boost, but I can't change CAS.

 

I'm pretty miffed about this. You advertise this product as 4-4-4-12 but set the SPD to 5-5-5-15 meaning the majority of users will not get the advertised performance.

 

:mad:

 

(oh, and I've played with the voltages, makes no difference, from 1.8v to 2.1v)

 

Zadkiel

Link to comment
Share on other sites

When set to Auto, the JEDEC standard defaults for DRAM are 5-5-5-15 @ 1.8v and without you setting to the extended settings of 4-4-4-12 @ 2.1v, it will default to the standards. Without these standards set to the DRAM's SPD settings, the system would not be able to boot on many systems when set to Auto or Default. This is standard for all DRAM and higher end DRAM doubly so, because the higher end DRAM supports non standard timings and speeds (Read Faster).

 

Enter your BIOS. On the main BIOS screen press Ctrl + F1. You will see the screen flicker. Next select the MB Intelligent Tweaker option. On that screen you will see many additional settings that were not there before http://i259.photobucket.com/albums/hh293/DerekT2008/GA-8N-SLI_BIOS1.jpg.

Download memtest from--->
and extract the ISO image. Burn the ISO image to an CD-ROM disk.

MIB Intelligent Tweaker (M.I.T.)

Voltages Control = Manual

 

Dimm OverVoltage Control = +.3V

Advanced Chipset Features

DRAM Timing Selectable = Manual

CAS Latency Time (tCAS) = 4

DRAM RAS# to CAS# Delay (tRCD) = 4

RAS# Precharge (tRP) = 4

Precharge Delay (tRAS) = 12

Refresh Cycle Time (tRFC) = Auto

Write Recovery Time (tWR) = Auto

Write to Read Delay (tWTR) = Auto

ACT to ACT Time (tRRD) = Auto

Read to Precharge (tRTP) = Auto

Command Rate = 2T

Boot to the Memtest CD allowing for two full passes.

 

Results?

Link to comment
Share on other sites

Enter your BIOS. On the main BIOS screen press Ctrl + F1. You will see the screen flicker. Next select the MB Intelligent Tweaker option. On that screen you will see many additional settings that were not there before

 

Well.... bugger me.

 

Now running at 675/4-4-4-12-16 and seemingly stable.

 

Thanks a lot guys.

 

Now to work out why Windows is reserving 1.5GB of addressable space, research shows that I might be able to reduce that a lot by disabling SLI - will try and test tomorrow (2am here now)

 

Zadkiel.

Link to comment
Share on other sites

I'm pretty miffed about this. You advertise this product as 4-4-4-12 but set the SPD to 5-5-5-15 meaning the majority of users will not get the advertised performance.

 

:mad:

 

No problem. You might take this as a learning experience and look to the following quote.

 

"There is a principle which is a bar against all information, which is proof against all arguments and which can not fail to keep a man in everlasting ignorance - that principle is contempt prior to investigation."

 

Be well :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...