Jump to content
Corsair Community

HX620W about dead?


Recommended Posts



I bought this PS about a year ago and since then I have always had a problem with crashing, usually when I gaming and thought it was ram (CPU never hits above 33c). I have replaced everything but the PS recently and now its crashing several times a day even when its idle. I also just started waking up to the crash while a alarm is going off. I just downloaded and ran Everest and Speadfan thinking maybe its the Ram (this PS has never crossed my mind till now) but everything checks out ok but Everest is showing my +12 V @ 8.51 V, -12 V @ 1.05 V and Speadfan is showing my +12v @ 7.34V. After searching this forum and if I read it correctly I just found out that my 3, 12v rails was a money saving Type-O and I really only have one 12v rail. Knowing nothing about PS and rails this sounds like this rail is way under spects. Is this how it should read till something makes it run 12v? How else can I test this without a muti meter, I really dont want to play around with the PS cause It seams like I dont have the golden touch and its more like the crappy touch... what ever I touch turns to crap.


Thanks in advance




*Edit how come I cant say the other C name in Ram?


This is my current system.


Operating System: Windows XP SP2 full update

Motherboard : Abit KN9 Ultra

Processor : Athlon 64 X2 6400 Black Edition

Memory : 4GB Crucial Ballistic Tracer DDR2 800


PS: Corsair HX620W

DVD RW : Asus DRW-2014L1T(Sata)

HD- Seagate Barracuda ST3200822AS (Sata)

HD- Western Digital Caviar 120 gig (IDE)

Link to comment
Share on other sites

If the 12v rails were really only providing the voltage that Everest/Speedfan is showing you, the system would not boot up at all.


Thanks thats what I wanted to hear. I will run that mem test again, its just hard to believe that if my ram was bad before then I just replaced it with more bad ram. But at the same time whenever a PS would act up on me it would completely die. I will follow the other guys link and check with a muti anyway.


To the other guy I guess the software must be lying cause the high history never has been over 33C and no I have never drained the water out of my system and ran it to see if it would register above 33C. Ill just take your word on that :)



Link to comment
Share on other sites

Well after a few more crashes and seeing data lost I took it upon myself and got a new Sata HD. No crashes for the 1st 24 hours and that was even after loading all my software except for GuildWars. I went to install that and had my mid of game download from the server and went to min the screen to read some news and poof crash. Windows error report said it was RAM, I ran the mem test once again and had 3 fails with in 10 mins. So I took out all the ram and ran them for 20 mins each then after that, I started adding a stick every 30mins with out a error. Once I finally got back to all 4 sticks together I ran for another 30mins and they reported ok again. Im going to download Prime as soon as I post this and let it run till this time tomorrow. I hoping what ever is wrong will just fry so I can be done with all of this LOL if not I guess I will just have to live with it.


As far as "errata" I dont know but Im also looking into that now too.


I also tested the PS once more and Im getting 12.1V so I guess my posts no longer belong here anymore so I prob wont post anymore except for a final update.


Thank you all for your quick replies and very useful information.

Link to comment
Share on other sites

IIRC, some of those Windows Error Reports can report the same error or type of error for CPU cache as well. It cannot tell the difference in which RAM is bad.


My best suggestion right now would be to experiment with 2 modules some to see if a lessened load will change the issue. It may help you isolate or eliminate some possible causes.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...