Jump to content
Corsair Community

Double Death of two Flash Voyager 1gb drives. Could linux be at fault?


Recommended Posts

Hello there, in advance I'm sorry for how long this is going to be but i want to give you the whole story.


I bought my first flash voyager at some point in the 2005/2006 school year. I can't remember exactly when. Anyway, it worked perfectly up until about 2 and a half months ago at which point it suddenly wouldn't let me access the files on it or write new ones. I attempted to format it using the windows formatting tool and even let the GNU Partition Editor have a crack at it. I tried the suggestions of how to get it working again on the corsair support site and that didn't work either. So I followed the other set of directions and sent it in to be checked and possibly replaced. Within a little over a week I got a brand spankin' new one of the same model in the mail and I was relatively happy despite the hassle and 2 bucks I had to pay for shipping. Because I got a new one so easily I assumed the old one had simply broken or something.


I plugged the new one in for the first time and found some true crypt folder on it...which i didn't want or care about so I just deleted it. Then I "Safely Removed Hardware" as I always do (or in the case of my Linux partition "Unmount Volume") and didn't plug it in again until I was at school ready to bring some of my Digital Photos off the computers there home on my newly restored flash drive. However, when I plugged it in again windows told me it was not formatted and asked if I wanted to format it. I said yes and, big surprise, windows was unable to complete the format.


So after all that I'm back where I started and getting a little annoyed. I just want a working drive so I can move data between various Win XP/ Linux systems.


I've looked around the internet for solutions and have tried a bunch of things that didn't work, I tried a RAMGUY suggestion for a person who seemed to be having a similar problem and got this:


C:\>Format F: /FS:FAT32 /U

Insert new disk for drive F:

and press ENTER when ready...

The type of the file system is RAW.

The new file system is FAT32.

Verifying 964M

Invalid media or Track 0 bad - disk unusable.


So the suggested course of action after that was to just get it replaced.


OK. Before I go though all that again, picking up a bubble envelope doing the emails. All that annoying protocol, paying yet another 2 bucks for shipping (yeah I'm very cheap, I know). I want to know if when I get yet another drive, is it going to happen again? At first I assumed the drive had just failed somehow after two years of fairly rigorous use..but after the second one I'm thinking maybe this could be something I'm doing that I shouldn't be and therefore breaking the drives. I mainly use Ubuntu 7.10 Gutsy Gibbon as my operating system. That was what I had booted when I plugged in the second drive for the first time and deleted the true crypt stuff. Is Ubuntu's "unmount volume" not the same as windows' "safely remove hardware"? Is there something else that should be done with Ubuntu in order to preserve the drive?


I can't think of any drastic changes in my use habits around the time the first drive failed that could account for all this, I'd been using it with Ubuntu with no problems for several months. I did notice that the packaging of the first drive claimed that it worked with Linux, the packaging on the new one didn't, has there been some change that makes the newer versions of this drive not usable with Linux?


My conflict in short is this: either this is my fault and I need to figure out what I'm doing wrong before I get a new drive and break it too. OR I have been unlucky enough to receive a faulty drive through the replacement support and could very well receive another and end up having to pay yet another 2 bucks for a product that I expected to last up to ten years.


I've briefly searched the forums and internet for solutions to these questions but haven't found much. Please forgive me if I'm asking questions that have already been answered elsewhere on the forums, at this point I'm fed up with scouring the net for similar cases. Thanks for your time and I hope we can figure this out.



Link to comment
Share on other sites

In order for the format to work, there has to be a valid partition on the drive. Boot up under linux and do a fdisk -l (lower case L). You can use a Knoppix CD or a Ubuntu CD if you don't currently have linux installed.


I've had cases where I could' use a drive under windows but was able to save it under Linux.


You can also do use fdisk to create a partition then do a mkfs.vfat /dev/sdx1 (substitute your USB device) on it. Make sure you do a sync command before pulling out the drive. Then it should work under windows. Of course it may really be damaged.


Another tip:

When you mount a USB drive under linux, use the noatime option in /etc/fstab or on the mount command so that linux doesn't constantly write access timestamps to the drive.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...